Forum Updated! 

Main Menu

Burned out Sega CD

Started by atom, April 01, 2004, 06:42:49 AM

Previous topic - Next topic


I was sitting on the john when i remembered my brother had this baby. I pulled it out of the closet, and went to go use it, and it wouldnt work. I vaguely remember years ago I may have possibly plugged in my NES ac adaptor in it, which i now have learned is 9v AC! Woops!

Is there a fuse anywhere on the PCB? Be pretty stupid if there wasnt, nothing on here looks like a fuse but im a little curious about this little green mobob.

forgive my broked english, for I am an AMERICAN


whole pcb - questionable green thing is circled
whats that other pcb? almost looks like some sort of mod chip
forgive my broked english, for I am an AMERICAN


Ehh sorry about this lawrence, you can delete this thread.
I went ahead and ripped out the green mobob and bypassed it, and it worked. It was indeed a fuse. Sorry for the triple post \ not figuring things out for myself.
forgive my broked english, for I am an AMERICAN


Be sure to replace the fuse; next time a surge could burn something important!


Yeah, fuses are there for a reason.  Also, when taking pics of parts with labels try not to obscure the label for us OK?  =)

Typically F is fuse, L is coil, R is resistor, and C is capacitor.  U is often used for chips.


Can you get us a nice clear shot of that brown thing?
I've not seen inside a MCD so I don't know if it's one of Sega's afterthought additions but would like a look anyway.


Well,  i saw some other pics of other peoples Sega CD's and it turns out that they all have them too. I can get you those pics tommorow probably I'm gonna be too busy today.

What about the brown connector to the left? Anybody have any idea what its for?
Maybe its some sort of developer port.
forgive my broked english, for I am an AMERICAN


I am having some problems as well... I got a sega cd system and I hooked it up and nothing.... I did notice the power led light up very very briefly.... so I checked voltave at the green internal fuse and there was voltage... so now I am stuck... not sure where or what to do now.   <_<  


This is a very common problem with Sega CDs, and when I worked at a game store while the SGCD was new and <cough> popular it was a common complaint.  

Unfortunately I was an electronics newb at the time and never could figure out why they failed...  Now that I have a moderately improved chance of solving the mystery I don't have the pile of dead units to play with.  =/


It would almost sound to me like a bios defect. But what the heck do i know?
forgive my broked english, for I am an AMERICAN

dum dum

umm, the bios is just a chunk of data the system can see and use, unless it has secret psychic powers it wont be popping fuses.. its just a dodgy system design thats all.

so what is the cream o' crop for the MCD anyways? there seems to have been only 20 or less titles released down in my area so i realy want to know what was kept from my kind


I've seen inside a couple of MegaCD2 units, they also have the brown board which looks like an afterthought, and the brown socket.

Very odd.



Dumdum probably Keio Flying Squadron, Final Fight CD, Snatcher and...? Sonic CD maybe. Although it is just Sonic with tree trunks.


I've got a broken Genesis 2 Sega CD also. Black screen is all I can get out of it. I, too, connected an NES AC adapter once I realized that the voltage and amperage more closely matched that of the SegaCD's label (Label says 1602 9v 1.3a I think, but most 1602 plugs are 10v >1.3a Genesis plugs).

I came here specifically to request that they start repair guides or at least a repair forum. I'd gladly donate this unit to anyone who thinks they can solve this for everyone else...


Oops... ^ That was me ;)

Oh, and BTW:
QuoteI was sitting on the john when i remembered my brother had this...
I'm sitting on the john RIGHT NOW (God-bless 802.11g)


I checked mine again... Mine has three of those green things in the same general vicinity. It does not have that add-on board which looks like a mod-chip.

Anyway, you know that little black thing with a coil in that is it is labeled "FL301?" Well, mine has a fully-enclosed box there with no visible coil. I suspected that a fuse must have been inside it bacause it also was labled "FXXXX" but after referring back here I doubt it. It almost looks like there's some way to pop it open and replace what's inside.

So, because mine has three of those fuses, should I just set my meter to "continuity test" and check all three or do I risk frying something by applying power (If I can even find my meter)?


Oops... Me again ^ ;)

BTW, mine does not have that port on the left and only has a ribbon cable going to the CD unit. Mine is a "Genesis 2-style" top-loader also.


This is interesting CZroe...
Im sorry i never got you those pics, i guess i will take some more of my unit so we can all examine it more, i remember a sticker on the bottom saying something about the unit being refurbished by sega or something...
forgive my broked english, for I am an AMERICAN