(X68000 XVI) Oh crap, what did I break?

Started by z964, November 20, 2023, 05:28:07 AM

Previous topic - Next topic


I recently got an X68000 XVI, and it was working well until I tried to install an Xellent30 68030 accelerator in it.

I did get the Xellent30 "working", but a problem has appeared where if I have the 16mhz switch on, the red 16mhz light will light up while the computer is in standby, but instead of turning green when I start the system, the 10mhz light turns green instead and the machine won't boot.  It will reliably boot with the switch in the 10mhz position.  Sometimes, I even got it to boot and work with the switch in the 16mhz position but only the 10mhz light would light up.  In that situation, I did get enhanced 16mhz / 33mhz speeds according to CPUPower even though the light said 10mhz.

I was also getting a lot of bus errors, illegal instructions, and such.  Especially when, possibly only when I tried to use an I/O slot gals panic ram expansion card.  That memory card had been working perfectly before the Xellent30, and had passed memtest68k completely.  I managed to run the mem test with the 68030 CPU at full speed and with only internal memory it passed, but with the ram expansion card it failed with a bus error at 69%.

So I took the Xellent30 out and put the original CPU back in place.  Unfortunately, the problems remain, except worse.  I can't get the machine to boot with the 16mhz switch on at all anymore.  I cleared the SRAM by holding CLR at startup and then pressing Y to confirm when the message appeared.  It didn't help.

As a final important note, when I was disassembling the machine to install the Xellent30, the card table I had it on collapsed and the machine quickly and roughly slid to the floor.  I can not detect any obvious physical damage on the motherboard or internal wiring, but I can't rule out physical damage.

Anyone have any idea where the problem might be?  The machine still seems to work in 10mhz mode so I can run tests.


Have you tried reseating all cables, boards, and the I/O box connecter?
After a fall like that I would assume something is slightly disconnected.

An odd issue for sure.


Check out this video as well.  Dude is saying you are limited to 10Mhz on that bus you are connecting the Xcell too.


Maybe that is why it won't step up?  It doesn't explain why it won't after you remove it though.  :/


I did reseat everything on the motherboard side of the machine - I/O box, video board, the ribbon and power cables at the bottom, and the cable connecting to the speed selector switch + led board at the top.

I didn't do anything with the opposite side of the machine.  Think that side could be relevant to this problem?

Thanks for the advice.


Regarding bus speed, I actually noticed that when I was messing with the Xellent30.  With the switch in the 10mhz position, I had a 10mhz bus, 20mhz 68030.  With the switch in the 16mhz position, I had a 16mhz bus, 33mhz 68030 (when it would boot at all).  It seems like its designed to actually work in the 16mhz position, and I broke something.


Update:  I took it apart again and put a mylar stencil sheet between the motherboard and its metal backplate.  This fixed the 16mhz light, which now lights up green when appropriate.  Unfortunately, the computer still rarely actually boots up in 16mhz mode.  It does suggest that there was a short circuit though.

One of the things that has to be done to install the Xellent30 is remove the RF shielding from the motherboard.  My guess is that when I did this, it affected the motherboard support somehow and made it contact the backplate.  Possibly I partially fried something on the motherboard with that short but I don't have the electronics experience to figure out what.  I appreciate any suggestions anyone has.


There's a bit of a trick with inserting the mainboard in the metal shielding back into the case.  If you don't line it up right the front of the board will be loose and can short against the shielding.


Spot on Watto. Common issue when reassembling these computers.