X68000 Super suddenly locks up with most software, can only boot Human68k 1.x

Started by UnbornApple, June 10, 2023, 09:01:16 AM

Previous topic - Next topic


Hello. A few months ago I bought a X68000 Super off Yahoo Japan. It had a rebuilt power supply and replaced caps. It has been working fine since I got it. I have been using it with a ZuluSCSI (external), a Midiori card, and a 2MB ram card.

This week I picked up a VGA monitor on craigslist, and it was working great with 31khz X68000 games. I had two VGA adapters so I wanted to make sure the other one worked, and I switched the adapters (without turning off the X68000). It was shortly after this I noticed some games not booting. Sometimes the mouse cursor would be on a black screen, but it would not move, appearing completely locked up. Nothing would boot off the ZuluSCSI. If nothing is connected (no SCSI or floppy disks) I would not get any error saying there's no disks in the drives, just a black screen. However some games would boot off floppy and work just fine.

Here's a video to demonstrate: https://www.youtube.com/watch?v=PffeRtv7a6s

Interestingly you can see an error message appear when I put in the memtest disk after it's locked up (I think it's just a generic "please reset the system" error), so it's not completely halted. But I can't consistently recreate this behavior.

I tried removing the SRAM battery without any change. The person who serviced this X68000 replaced it with a 3V CR2450. I think the original battery is 3.6 or 3.7V, could that be a factor? I also removed the Midiori and RAM, and unplugged anything else unnecessary like gamepads, without any change.

After trying lots of different software it seemed like only software based on Human68k 1.x would boot. Anything higher would freeze. I was able to run the SRAM_CLR.R program without any change. I have no clue how to use the version of Switch.x that's included in H68k 1.x, and newer versions won't run on older version of the OS. I'm not sure if it's actually clearing the SRAM. Switch.x still says I have 4MB of RAM--wouldn't it reset to 2MB if the SRAM was cleared?

Is there anyone that's familiar with the difference between H68k 1.x and 2.x? That could give a hint as to what the issue is.

I haven't taken it apart yet, but that's the next step. I'm not expecting to see anything noticeably wrong. I think if this was a capacitor issue or something I would be having different issues. Maybe this is an SRAM, ROM, or some other IC problem. Maybe this is some SCSI issue and H68k 1.x works because no SCSI drivers? I did also try booting a newer version of Human68k and REM'd out all of autoexec.bat/config.sys lines, but it still locked up.

Any other suggestions or ideas would be GREATLY appreciated!


So I was right, the SRAM had not fully cleared. You really need to let the X68000 sit overnight, I guess. With the SRAM cleared I now get the typical "Insert a disk" message instead of a black screen, but the issue still remains with most software locking up on boot.

I DM'd cyo and he suggested using an XVI IPL ROM, so I'm reading this thread to see if it can cure what ails my X68000.


For clearing SRAM I would use the debugger, see the bottom text here: https://gamesx.com/wiki/doku.php?id=x68000:sram_issues

The other programs never really worked properly for me.

Start by removing the add-on boards from the system at least - you want the most basic set up possible to eliminate other possibilities.  You can boot off drive 1 instead of drive 0 etc. to rule out the drives.

My guess for your issues could be bad RAM.  The problem is with these re-capped/refurbed systems nobody can really say for sure how much work was done, eg. maybe just the PSU and IO board were recapped.  Ultimately it will probably need to be sent off to someone who can properly examine the system.


I wasn't able to use the debugger because I wasn't able to boot the C Compiler PRO-68K disk. I think I tried booting a H68k 1.x disk and then running the debugger, but it would not run on an older version of the OS.

The RAM did pass Memtest68k. I think there's another memory test program out there (MTEST), but I haven't tried that yet.


An update to my saga: I was never able to get ahold of different IPL roms to try, but I did win an auction for a banged up junk X68000 Super to see if I could use it for parts.

I took the main board from the "new" Super I got and put it in to the one where it won't boot Human 68K 2.x/3.x disks. I still had the same issue. I also tried using the video board from the new one, with no change.

So the next step was to try the I/O (bottom) board. Swapping that did show different behavior, but for the worse. Now it starts to boot with a blinking green LED the second it's plugged in, even if the soft power switch is off. It displays a message that translates to "An error has occurred. Please reset the computer." If you turn on the power switch the blinking green turns solid green. A previous owner did put a coin cell battery holder to replace the battery. I may desolder it and see if there are any broken traces under there.

So in summary I now have two non-working X68000 Supers 😆