X68000 Compact XVI + X68030 Compact Repair / Restoration

Started by BlueBMW, June 04, 2012, 04:58:37 AM

Previous topic - Next topic


Apologies for necrobump, happy to have this deleted and make a new topic if deemed necessary.

Anywho, I'm currently trying to open up my compact and progress has halted at removing the front face-plate. The clip up the top, next to the power & interrupt buttons doesn't want to let go. I'm cautious of breaking it permanently, so does anyone have any advice?

The wiki says to "lift" it, which I've tried with a jeweler's flat-head screwdriver - barely - since there's not exactly much room to get anything under the clip to lift with and I'd prefer not to use the buttons as a brace to lever the clip in case the buttons break.

Can anyone offer any advice?


About then years ago or so there was a Compact XVI disassembly video on YouTube. Not sure if it is worth anything, but you might give it a peek.


Quote from: kamiboy on September 30, 2022, 07:13:57 PMAbout then years ago or so there was a Compact XVI disassembly video on YouTube. Not sure if it is worth anything, but you might give it a peek.
I've found a total of two, one from a guy who stands roughly two meters away and pulls the shell apart without any detail (and I suspect there's clips missing/broken).
The other was made four months ago from a Japanese owner who I think lost the footage of the part I'm looking for, so no help there sadly.


New user here, just got a Compact, and of course both drives are dead, one deader than the other. One was completely stuck, I've replaced the caps, all good electronically, but still not working.

The other, no maintenance yet, was attempting to read, was ejecting, and yesterday, out of nowhere, the eject mechanism started to keep running all the time, and the drive smoked...

So now I have no drives, and the system won't boot without at least ONE drive. It started to give me all sort of weird responses. Like this:

And it wouldn't power off: the green light kept blinking, and the computer wouldn't shutdown. I had to push reset, and then quickly hit the power button, and then it would go red (off).

Sometimes if I insisted in pressing the reset button I'd be greeted with this one:

There are two solutions for this that I've learned from a Twitter friend just yesterday:

1) You can connect only the top board to the flat cable, and if it "answers" back to the computer, you're good. Proof:

2) If you don't have *anything*, no drives, no boards, nothing, not even the flat cables, the trick is to partition your HDD in two. Here's proof of mine with NOTHING but the two flat cables:

I have an Aztec Monster CF interface and I've created a 997MB disk image.

First partition has 995MB, bootable, all good.
Second partition has 2MB, select it as "Usable". Don't mark it as bootable.

You can do all this setup without your real X68000 Compact, I've done it all on the XM6g emulator. When it was ready (I've manually copied all the files from Eidis V4 HDD image to it), I've used WinImage to burn the image onto the CF card and it worked PERFECTLY.

It boots with the "HDD" as drive A: and the second partition as drive B:


Hope this helps somehow. The computer was not booting AT ALL without this trick. And now it's working fine:

Sorry if this is known knowledge, but I've been stuck with it for almost a month now, and I didn't see this about the partitions anywhere.

And yes: you can buy a X68000 Compact with **no FDD drives** and the computer will still work if you do this partition trick.