X68K Super - after a BUS ERROR stopped booting from SCSI and OS 3.02 floppies

Started by Corummo, August 13, 2022, 07:11:07 AM

Previous topic - Next topic


Hello everyone. :)
I'm a proud long time x68k Super owner and, after many years of pause, I finally decided to bring it back on the desk.
I managed to successfully configure an external scsi2sd board, with a v4 image. By setting Switch to boot from SCSI ID 3, I was able to start the machine straight from the sd card. Total happiness!
After two days of pure joy, I started to get some read error from the sd card, with the typical Abort/Retry/Ignore prompt. About an hour later the system popped a BUS ERROR warning that led to a complete freeze, leaving me with no options but a brutal power-off.

From that moment on, my beloved x68k stopped any interaction with the SCSI chain. I used to see led blinking at power on and during the SCSI bus scanning. Obviously it blinked for every access as well.

Right now I have no signs of life from the external scsi drive. No led blinking, no bus detection and - the real worse fact - the system stopped booting from anything but an OS2.0 system floppy, that brings inside the SX-Windows environment.

Fortunately I have a mouse and was able to run Switch from the GUI to restore the original boot settings.
But I had no "insert boot disk" picture anymore. The screen simply stays black. If I force an OPT1 reset, I manage to start the pc with a floppy as happened before but.. if that floppy has any relation with OS 3.02, the system simply refuses to boot, standing still with an empty black screen which I can overcome with a reset or an interrupt press, which shows the usual "there was an error, please reboot" message.

I desperately loaded the SASI bootloader inside the SRAM space, which starts as expected, scanning the whole SCSI chain with no result and bringing up the "insert a boot disk" picture, as it should be by default.

The SCSI2SD board is perfectly fine. I can detect, read and flash it from my Windows PC. The SD card is error free. Both X68K floppy drives are fully operational. I opened the machine and reseated the floor daughterboard a couple of times. At a visual inspection, caps seem to be fine. There is no dust, no leakage, the SRAM battery has been replaced by the previous owner, who installed a rechargeable coin cell.

I tried any combination of SCSI termination, SCSI2SD configuration and even removal, BOOT combinations and options with and without specific SASI drivers, SRAM erasing. Nothing solved my problem!

I read these boards like crazy from three days now and found some kind of similarity inside this thread, which covers the same attempts I did.

I suspect a SCSI controller failure that gets ignored by OS versions prior to 3.02, allowing my system to boot. Otherwise I'd be doomed to watch a stuck machine that is turning into a stylish and expensive paperweight.

I'm open to all of your suggestions. I love this computer so much and I'm gonna do everything I can do to restore its full potential.

Sorry for the very long post and thanks for your time.