Bus error causing crashes while using MIDI - X68000 XVI

Started by incrediblehark, September 01, 2021, 08:47:40 AM

Previous topic - Next topic


Been trying to sort out the quirks with my X68000 system, and here is another one. I'm testing out the aje_fr ram+midi card (just midi enabled) and I'm getting a bus error almost every time I play. This seems to happen randomly but always crashes at some point. Mainly testing with Akumajou Dracula but also has happened with Gradius II and others. Waiting on an SC55 to come in the mail but right now using an MT32pi setup.

This X68000 XVI was purchased a few months back and has been recapped/refurbished and overclocked with the BEEP XM6BE6AP internal ram upgrade. So far I have tried 10mhz and 16mhz. I have tried reseating mdi card, changing settings on the card, reseating ram and I/O slot riser card, and cleaning contacts of I/O slot. This is using a SCSI2SD with v4 image.

Anyone else experience these issues or have any suggestions?


I would guess RAM settings are wrong.  It seems that MIDI board has a switch to enable/disable the RAM.  Maybe, some games are still detecting the extra RAM even though it's "disabled."  Maybe enable it and check your jumpers and switch settings?

Have you tried removing the Beep RAM board and just use the MIDI board itself? 


Thanks for the advice, I'll see if I can test it without the beep internal ram board. It's wired up for the overclock so it won't be as simple as just removing the board and testing though.


So a quick update to this, I think I found what was causing my bus errors... my stepdown transformer was bad. Just completely burned out on me last night. After running the X68000 directly plugged into my surge protector I have not had a bus error since (yet...)

Any good recommendations on a replacement transformer? Being in the US, should I even bother using one? Just want to take care of this system as much as I can.

Now if I could figure out my conflicts with the RAM portion of my aje_fr card and the BEEP card, that would be great!


I think your RAM problem is because of the overclock.  The mobo ram expansion port supports faster speeds than the i/o slots.  On X68000 RAM is configured as one big continuous block.

You said your mobo RAM expansion is wired to the overclock right?  The i/o slots can't run RAM that fast.

A lot of old i/o slot RAM boards produced before XVI existed don't even support 16mhz.


Thanks for your help with this, and I may have spoken too soon as my bus errors are back. I need to see if I can figure out reversing this overclock, because I know the system will not boot if I just remove the BEEP ram module.


Ok, I managed to disable the overclock. Was actually very easy. Anyway SuperDeadite I think your original reply is accurate. The ram settings of the aje_fr card and my beep internal ram card do not play nicely.

With beep ram removed and no OC - get 10mb ram and midi playback with no bus error.

With beep + midi card and no OC - bus error. This occurs even when I have the midi card set for ram disabled (0). If I set the dial to 8 as intended, the x68000 will not recognize the additional 4mb ram at all. If I dial it back to 6 or 7, the system will show 12mb in SI but there are address errors, obviously. MTEST errors out no matter what settings with both installed.

I'm wondering if I'd be better off selling the midi+ram card and looking for an original midi card or a midiori? I can get rid of the beep card instead but I'd have a dummy switch installed in the back and it didn't seem like the overclock made a difference.


Here's an update to my current situation:

I am still experiencing bus errors. This is with or without an overclock installed, all other ram mudules and i/o boards removed, and regardless of whether or not I have ram enabled on the aje_fr card. Changing the address settings of the midi with the rotary switch did not produce any different results.

Other issues I've encountered are the midi not working with any Capcom game I've tried, and the game Geograph Seal will not start at all with the midi card enabled. This is either from floppy or from the hdd image. If the midi jumper is set to off or the card removed it plays fine, otherwise the game hangs right at the boot screen.

This has occurred with an mp32pi device as well as a roland sc55 mkii. I have reached out to aje_fr again as well, and I appreciate his patience and support through my troubles. Here is the screenshot of the bus error from Akumajou Dracula. I want to post this in case anyone else has any suggestions:



I believe so, but I will do some more testing to confirm this.


Just wanted to add a final update, I was able to acquire an original midi card and have not had any issues since. So I just think the midi+ram card was not playing nice with however my configuration was in the XVI. I honestly have no reason to believe the aje_fr card is faulty, I'm assuming it was some sort of I/O conflict.

Edit: just adding here for accuracy - the aje_fr card was indeed faulty. After selling the card to a user here he worked with aje_fr to reflash the card and resolve the issue. There was nothing wrong with my setup on my end. Just a lot of troubleshooting and speculation.