X68000 Pro - D.O.A from Yahoo Auction

Started by megatron-uk, June 17, 2020, 01:50:19 AM

Previous topic - Next topic


Because of course it would be, wouldn't it?

It was pretty cheap, and listed like 99% of all the other X68k's as "Power on - untested"... or words to that effect. It was pretty filthy, but actually, apart from some scratches in the top metal cover, it's cleaned up really nicely.

It arrived today, and of course, only the red power light comes on (I wasn't expecting anything else)... no signs of life from the power button or on the video output (AD15-HD15 adapter into an OSSC). Sadly no goodies inside the case, but I already sourced a 1MB upgrade, an XSIMM10, MIDI card and an original Sharp SCSI card.

The plan is to pull the PSU out, fit a 90w PicoPSU and one of Edu Arana's ATX to X68000 adapter boards. Hopefully when it's all working again I'll use the SCSI card to natively boot from an AztecMonster that I've had sitting in a Mac IICi that I no longer use.

I'll post an update when the PicoPSU bits and pieces arrive and will also add it to my blog: https://www.target-earth.net/wiki/doku.php?id=blog:x68_pro_fault


I've got all the bits now to start replacing the PSU, so I decided to gut the PSU today (already removed from the case) to see what was wrong, and to cut off the wiring to reuse the connectors.

On first glance there wasn't much to see, maybe some discolouring around the base of several legs and where the wiring is soldered on to the board:


But on flipping the board over....



... a truly horrendous amount of corrosion from those fairly huge capacitors! It's proper nasty, wet to the touch. Yuck. And having seen that, I looked a bit more carefully at the top of the PCB and it was easier to see that most of the vias were actually fluid-filled and discoloured:


Wow. That's a proper failure!

The inside of the X68000 is super clean and there isn't the slightest sign of failed caps or even battery failure in there. The PSU almost looks like it has come from a completely different era and working environment!

I've got my Aranet ATX adapter and PicoPSU lined up to go in the case next, hole is drilled under the original AC socket for the 12v DC jack and I'm using one of the strengthening bars to mount the PicoPSU to. Should end up fairly neat.

Fingers crossed I'll have the work done by the end of the day....


So two steps forward, one step back.

Fitted the Aranet board and the PicoPSU... and the X68000 powered up again... briefly.

It powered on (green power light, yay!), but then started crackling from the speaker and within 2-3 seconds caps C241 (not C221, as I wrote earlier) and C243 (which are both rated 100uf 16v, 85'c) went pop and I immediately turned it off.

img_1591.jpg img_1592.jpg


I guess it is going to be a full board out and recap job then :-(


Since there wasn't a capacitor list for the Pro in the wiki, I just made one:

6x 0.47uF, 50v
9x 4.7uF, 50v
2x 1uF, 50v
1x 10uF, 16v
1x 22uF, 16v
1x 33uF, 10v
7x 47uF, 16v
3x 100uF, 6.3v
4x 100uF, 10v
5x 100uF, 16v
1x 220uF, 6.3v
5x 330uF, 6.3v
3x 330uF, 16v
1x 470uF, 6.3v
3x 470uF, 10v
1x 3300uF, 6.3v

That's only the radial electrolytics. I didn't list any of the bead types.

That's over 50 caps to replace, and 16 different ratings, too. Urgh... I just want to through this thing through the window right now....


Hehe, I've recapped 5 X68000 so far, and two of them turned out to be waste of time as the machines never ended up working. I actually kind of like the process, there is something so very zen about it since it requires all my of concentration. Or it might be all the leaky cap fumes getting to my head.


Caps ordered... hopefully they'll arrived this week (I'm on leave from work!) so I can get started quickly. What I'll probably do first is just replace the two that failed and try it again to see if it was just inrush current to two flaky caps, or if there is something else wrong thats more fundamental (which I'm not knowledgeable enough to solve myself, being honest).


The replacement cap set came... and I bought plenty of spares.

It's a good thing that I did, because:



Same behaviour as before:

- Connect power and red standby light comes on
- Press the power switch and the green light comes on
- Within a second or two the speaker starts to crackle and C241 and C243 blow.

That's only C241 and C243 replaced, btw... but I'm really reluctant to spend several days redoing all >50 caps if there's something more fundamental wrong which is causing them to blow consistently.


Any suggestions?


So to spare any further testing of the Pro directly, I measured the voltages coming of the PicoPSU via the Aranet ATX adapter:

+5v SB : +4.91 - 5.05v
+5v PC : +5.02v
+5v : +5.02v
+12v : +12.04v
-12v : -15.56v

Erm... Is that -12v line the problem? It's more than 25% out of spec.

I suspect that the -12v may be used in the audio/amplifier circuit? That's just a guess though, knowing some of the PC audio hardware of similar vintage to the X68000 which requires a -12v line on the PSU.


Looks to me like the -12v is unregulated.   Is your PicoPSU a fake?  I'm not sure modern PCs really need the -12v these days so might be "fine" to be unregulated on modern boards as in most people won't notice it.  You could try detaching the -12v although don't know if that'd cause issues elsewhere.

Seems unusual they'd pop though, I'm assuming you've got the polarity right.

I'm trying to fix up a X68000 I got yesterday, will be doing the full recap too by the look of it, so might have some better ideas in time.


The PicoPSU wasn't supposed to be a fake. But there's always a chance that it is. I've ordered a genuine one from Mini-itx.com which is supposed to be arriving today.

I'll plug it in, leaving the ATX to X68000 header disconnected and see what the -12v line is putting out. Like you say, it could be unregulated as most PC's don't need it these days... as far as I'm aware, it was only ever an optional voltage on the ISA bus.

Polarity was definitely correct, according to the original caps on the board and the silkscreen polarity markings.

Fingers crossed that it didn't cause any more serious damage.


Looking at some schematics it looks like the OP amps use it.  I would've thought maybe RS-232 also but can't see that on the older schematics. FWIW I measured mine and it's low but within tolerance (just under -11v).  Wish I had a Pro, could try to follow the traces for you and see what it's connected to.

In my case it's an Ace HD, someone appears to have had a stab at fixing the IO board after battery leak.  Seems in a real state, found a burnt diode, some traces look like they still need repair, etc.

Would love some schematics for it as some things on there appear to be bodged.


Well the replacement PicoPSU just arrived via DPD - just taken the voltage readings compared to the original:

+5v Standby : +5.06v
+5v Power Control : +5.06v
+5v : +5.06v
+12v : +12.2v
-12v : -13.6v

The +5v lines are slightly more stable (well, at least as much as I can see on my ancient Fluke 75). The -12v line is still higher than spec, but it's barely 10% above the nominal rating; compared to the almost -16v (25% above spec!) of the original PicoPSU.

Hopefully I'll get a chance to desolder those two dead caps (again) and replace today. Fingers crossed....


Just replaced the two caps and tested it again. Pop. Again.

I did notice some odd behaviour of the power light though, which I didn't pick up on previously:

Immediately on plugging it in and switching it on at the wall, the red standby light comes on, within 2-3 seconds it goes out and comes on green - without pressing the power button.

About half a second after the green light comes on, pop goes the caps. Though this time only C243 went pop.. not sure if that's just because I yanked the power cable faster than before though.


Okay, so I know what the problem is.

It's partly that I'm a moron and should verify every single source of information, but also partly that the X68000 Pro PSU schematic wiring colours do not match the wiring to the Pro motherboard header.

The PSU schematic states:

Orange: +5v Standby
Yellow: +5v Power Control
Blue: +12v
Brown: -12v
Red: +5v
Black: Ground

But the old power supply repair documentation, actually has the correct colour codes:


So the two documents have +5v PC and +12v swapped, as well as +12v and -12v... and the latter is correct, because:



I can only hope that when I connect back up the rest of the components that nothing has been damaged beyond repair :(


Sorry you had that trouble, @megatron-uk

I've just updated the PDF based on your discoveries, along with a note to check the colours.

Revised schematic (Same URL as the old one).


So, at least the video output is working:


There's a bit of background hiss from the onboard speaker, as well as through headphones when connected to the rear 3.5mm jack... so there's likely some of the audio circuitry capacitors need replacing (not surprising, considering the abuse they've just been through).

I'll try to work out which ones those are (they at least include C241!) and replace them before moving on to floppy drives, keyboards and then ultimately the IO slots for my midi, scsi and xsimm cards.


So I think the audio noise is actually the volume pot at the front - if I turn it up or down slightly the noise goes away, so I expect it's actually the pot that's at fault, not the rest of the audio circuit. Though I won't know for sure until I get the rest of the system assembled and capable of booting a game.


So the floppy drives work, at least partially; I wrote a copy of masterdisk_v3.xdf to a floppy and I get this:


Both drives have working power eject, though only the upper (drive 0), appears to read the disk, the lower drive spits it back out almost immediately. I can hear the floppy being read (disk light changes colour) for maybe 3 seconds, then it stops with the above message.

I do currently have all my cards fitted (SCSI, XSIMM and MIDI), so I'll take them out and try again.


It's not any of the cards - I removed everything; the IOData 1MB expansion, and all of the IO slot cards - no difference.

Hmm... keyboard doesn't appear to be working either, which may be a bigger problem. I've got one of the Aranet PS/2 adaptors and there are no lights showing on the keyboards I've tried, and it doesn't respond to any key presses (e.g. if I press interrupt as the floppy is seeking, neither (A), (R) or (I) does anything).


I guess the next job is to see whether there is any power at the keyboard port.


Keyboard pin 1 should be connected straight to the 5v in if my board is anything like yours.  I'd be surprised if it's just that at fault.

Meanwhile trying to see if my Ace IO board is actually salvageable.  If you're going to clean up after a battery leak, please do it properly.  So far looking like most of the traces are there at least.  No idea why you'd go to all the trouble of trying to fix traces but not clean the rest of the board properly.


If I try the Motos floppy, the system actually boots the game fully:

Sound is present, but very low - the volume control needs to be cranked right up. Again, the keyboard has no effect.


I'm thinking I'm going to have to go back and do a full re-cap before trying anything else.


Quote from: watto on August 03, 2020, 06:54:09 PMMeanwhile trying to see if my Ace IO board is actually salvageable.  If you're going to clean up after a battery leak, please do it properly.  So far looking like most of the traces are there at least.  No idea why you'd go to all the trouble of trying to fix traces but not clean the rest of the board properly.

Urgh. It doesn't actually take much to clean a board up, why bother trying to fix things and just leave it as a ticking time bomb for the future?


Quote from: megatron-uk on August 03, 2020, 07:52:54 PMUrgh. It doesn't actually take much to clean a board up, why bother trying to fix things and just leave it as a ticking time bomb for the future?

Looks like the tracks are actually OK, went around the lot of them and confirmed connection with IOCS. I had to dig out a lot of crap in the clock/reset area, basically stuff that should've been treated when the battery was cleaned up originally and turned to muck/rust.  Amusingly the replacement battery they put in would've never worked because they didn't fix those traces.

Seems like that diode I found early on is likely to be causing some troubles, as it's connected to power signalling.  Hoping that plus doing all the caps they didn't bother with will sort things out and then I can paint all the copper they've kindly left exposed.

Interesting thing is the schematics I've found (for an XVI) are pretty much identical to the ACE with the exception of what looks like the battery charging circuit, the IO chip, and sticking 2 in front of every component number.  Apart from a few components here and there.  Makes me wonder how exchangeable these boards are between models, at least some of the earlier ones.


I read this threat with interest while i had my odysey with my X68000 (First Modell) and my XVI.
Bought the X68000 without Keyboard and Mouse it took a while until i got these.
Built a VGA adapter and i could play some titles.
On one time i got Mouse and Keyboard adapter from 8bitly and the X68000 experience was great.
Followed by an 1mb Ram extension the fun was greater
But on that time the PSU was gone - replaced with ATX and the fun could go on.
Next i got the XVI - from beginning the PSU was faulty, replaced and tried Star Wars on both Machines with a Quickjoy with 2 cords. That blews the NEC I/O Chip - so soldering was the next step.
Then  i got an Arananet scsi adapter - from that time the XVI doesnt bring any Video - the Powerplug was junk.
Between some repairs the softpower of the X68000 was faulty, can´t remember what was the problem.
So you see i got many repairs - but i didn´t do a Full recap and none of the problems was solved with new cap.

So is the low sound on the internal speaker, on the Headset or on the audio out on the back ? Could it be a blown OP Amp ?

The Problems with your drive 1: - my X68000 sometime doesn´t spin the Floppy. Seems that the motor doesn´t start. I have to shake the X68000 a little bit an it starts working.


I'm on re-capping the main board (CPU, RAM, etc) now, though there's only a couple of caps, with most of them related to the video out (which is working, so I don't believe any of those are problematic).

The big job is going to be the sub/IO board, which has at least 35 individual caps. Not looking forward to that one.

A blown op-amp is a distinct possibility, given the power supply wiring issues earlier.


Keeping my fingers crossed for you.  A blown Op amp wouldn't be that bad in the context of things and shouldn't be too hard to track down at least.

Hopefully once a couple more bits arrive I can get the recap fully done, put a new diode in and see if any progress is made on my issues.  Suspect I'll be working on mine for a while yet.


Argh! Just realised I'm short of a 33uF and the big 3300uF caps from the main board - I've got all of the others on the main board and sub-board at hand, but those two must have slipped from my order when I was putting it together.

The ground plane on this Pro main board sucks up a hell of a lot of heat from my desoldering gun, I've had to turn it up to 385'c to get some of those cap legs to move.

Also the op-amp on the sub-board is labelled as a "2073D JRC", a fairly cheap IC (£2-ish)... there's plenty on Ebay, so I may as well pick one of them up.

The only other thing I was considering was whether to replace the volume pot - it's clearly worn, so it might be sensible to do it at the same time... it seems to be an Alps 103B according to the numbering on the part itself. Anyone know an alternative?


Ok, so except C44 and C56 (the two missing parts I don't have), the main board is now done.


(ignore the 'rust' in the memory expansion socket... it's not really there, I think it's just an artifact of the lighting)

I think that's probably enough for today. I'll start on the sub-board tomorrow.


Main board complete - including the missing caps from yesterday (overnight delivery from Farnell).

I've got the sub-board/IO-board lined up to do next, but I thought I'd take a look at the floppy drives... and as usual with the Pro, they're entirely different again.

The drives in my machine are actually TEAC FD-55GFR units which can be found (slightly modified - no motorised eject) in PC's and other machines.

Of course there's no info on these, so I had to do my own capacitor list again

Number   Location   Capacitance   Voltage   Notes
C1   Edge connector board   ???   ???   This is populated, but the cap seems to not have any ratings printed on it!
C2   Edge connector board   22uF   10v   
C3   Edge connector board   100uF   10v   
C4   Edge connector board   10uF   25v   
C23   Edge connector board   6.8uF   50v   
C24   Edge connector board   Not fitted   Not fitted   
C25   Edge connector board   6.8uF   50v   
C26   Edge connector board   Not fitted   Not fitted   
C54   Motorised eject board   22uF   25v   The only cap on the board.

There's also the motor/spindle board itself, but it looks significantly more complex to take apart than the other drive types in the wiki.


Caps on the drive spindle/motor board are:

C101: 22uF, 16V
C107: 0.47uF, 50v

There are also a couple of ceramic caps, 2 on the edge connector PCB (C11 & C12, two of: SR 104M 12v), and 1 on the motor board (C104, labelled as 16X 100M).

I'm unfamiliar with ceramics and their labelling, so I'm not sure what these are equivalent to.


Normally wouldn't bother replacing anything other than electrolytics, unless they are specifically broken.

That said if you insist, the 104 means 0.1uF (u as in micro, don't know how to do that symbol.)  M means +- 20%
100 is 10pF.

The 16X doesn't mean anything to me.


Ok, will leave the ceramics for now.

While I'm on I've ordered a pair of replacement MC3403P op-amps ic's (I suppose one is for the front panel connector and one for the rear) and the 2073D amplifier chip (guessing this is the case speaker). I'll probably fit them in DIP sockets to make any future replacement easier.

Other than the audio, the main thing that is bothering me is the keyboard. Is there a specific keyboard IC, or is it rolled up in to some combined controller like the MC68901?

Also, 27 caps left to replace on the sub-board. Although I've got a good rhythm and technique going now (snip the cap off, straighten the remaining legs, flip board over, heat and straighten the leg not on the ground plane, heat and re-solder the leg on the ground plane, go back to the first leg, heat and suck... repeat until clear, moving between caps if one proves troublesome), so I'm doing 4 or 5 at a time.


Okay, so tracing it out, and comparing to the original X68000 schematics, the keyboard seems to be connected as follows:


On the pro, the equivalent appears to be:


If it's any of the first three at fault, then that's easy to resolve - they're all standard 74-logic ic's. However IC7/IC234 is a custom Sharp peripheral controller chip (LH8530AP). So it's unlikely to be easy to replace.




For the Pro I'd check whether the CZ-634-TN/CZ-644-TN schematics are any closer.  From what I've read, the biggest changes happened from the OG X68000 to the ACE, after that they were more minor changes. I know the Pro is somewhat of an exception in some ways so see which works best for you.

At the point you're at I'd be looking to check for signals using an oscilloscope or logic probe starting from the connector and working my way back.  I'm guessing you don't have either though?

Was the keyboard plugged in while you had the voltages switched around?  If it was, check that first as it would've been affected too.

What I'd do assuming you have no probe or scope is start with the more easily obtainable/replaceable parts in the area.  Looks like an LS08, LS244, if you see anything smaller like a transistor on the way to those, might want to change that first, but it looks like most things on that line are connected almost straight to VCC2 (5VSB) which I'm guessing was being fed 12V instead of 5V?

All this will be easier if you have some way to check the inputs/outputs on these chips for logic levels at least.

You may want to socket these while you are replacing them too.  Compared to pulling out caps, or anything with only two or three legs, cleanly getting out a chip with several pins can be pretty difficult.  The X68000 boards seem quite resilient so far (compared to some other boards of similar vintage I've worked on) and they appear to be using nice old lead solder so hopefully manageable for you.

The SCC is fed from VCC1(5V) as well it appears, so on a different rail.  Mind you that looks to be the same rail those caps that blew are on, so you never know.  It's a pretty standard chip at least.

I would still say hold off until you've got the replacement caps in at least.

And double check what I've said, as I don't have a Pro so guessing off the wrong schematics.


No, no oscilloscope or logic analyzer.

I'm not planning on doing anything else until I fully complete the entire recap of all the boards and replace the audio amps... it is pretty handy though that most of the components on the boards are through-hole, there's only 10 chips in the entire system that are surface mount (mostly the custom Sharp units).

Since it actually turns on, runs and plays games, and has (quiet) audio, I'm really hoping that there's not much more wrong. Nothing other than the main board and sub-board and front panel power board were connecting during the power test earlier, so the IO riser and cards, keyboard dongle + keyboard, memory upgrade module, floppies etc would not have been subjected to the incorrect voltage.


My ACE is working to some extent too, although I've found some more damaged components around the soft power area (eg. resistor with a leg fallen off) the thing would still turn on, show picture, etc.  Main problem with it is to do with the floppy drive handling but the problem there is on the IO board and nothing to do with the drives.

It seems like they can take a bit of punishment anyway given how messed up the IO board on mine is, it's still almost working normally.

Once the caps are done if the keyboard still doesn't respond double check the voltages are coming through where they should, check for any other small components around that look like they may have suffered, then get ready for some un-fun times..  I'd recommend getting a logic probe at least as they aren't that expensive and it could save you a lot of time and messing about.  You could easily spend more unnecessarily replacing components instead.


Progress so far on audio section of the sub-board:


Done about half the caps on this board, there's about another 15 or 16 to go. Got the two MC3403P op-amps desoldered and DIP14 sockets fitted in their place, also got the 2073D amplifier chip removed,
but I'm waiting for a DIP8 socket to arrive for that one.

The op-amps and amplifier IC chips themselves should be here before the weekend.

I was also considering replacing the case speaker (0.5w, 8Ohm) as well, but I can't find an exact match - I'd like to put something a bit better in its place if possible, but it's difficult finding something that will be driven reasonably well be the 2073D; my guess is that anything over 1-2W is likely not to work too well with the tiny amp.


Fitted the 3 replacement audio IC's (2x MC3403P op-amps + 1x 2073D amplifier) in sockets tonight as well as a couple more caps.


Only have 5 more caps to do and then that's all the electrolytics on the main, sub and floppy riser boards done.

Haven't done the floppy drives yet, but there's only about a dozen or so to do in total there.

I guess then we try again...

I think at last count it was something like 54 electrolytic caps on the main boards, the floppies take it up to 66-68 or thereabouts. Not something I want to do again in a hurry.