Troubleshooting the Saturn Controller Schematic (w/74xx153 ICs)

Started by T_O, September 26, 2019, 02:00:42 AM

Previous topic - Next topic


Okay everyone, this one I'm certain is something I'm doing wrong because the circuit is so simple. It's the GamesX Saturn controller schematic (see image), and I'm having a difficult time getting the console to recognize it.

Key things to point out:

1. I'm using an OEM controller cable from a working gamepad.

2. The schematic names the ICs as TC74HC153A (Toshiba); I am using 74HC153E (Texas Instruments, PDIP).

3. The console behaves the same with the project controller plugged in as when there are no controllers plugged in. When an Action Replay cart is in, the menu instantly goes to Select Game > Search > cursor goes down repeatedly to the "." character on the search input interface and keeps trying to go down (so it rapidly stays on "." and blinks infinitely). Again, this behavior is the same as when no controllers are plugged in.

4. Using a breadboard—the same one I got the PS1 controller schematic to work on. All rails are properly connected and "jumped" in the middle of each rail. I will post an image of my BB's connections later today, if necessary.

5. I have double- and triple-checked each connection. ICs are getting correct voltage and grounding.

6. I have tried 47K and 10k arrays, same result.

7. Pin 3 and 13 of U1 are kept low. Pin 3 of U2 is kept high in the array.

8. I have several 153s, so I've tried swapping both chips. No success.

9. Yes, I've made sure other gamepads work in port 1. They do.

Has anyone else attempted this schematic and encountered the same issue? Any help is appreciated, thanks!