1MB expansion not recognised

Started by Dal, February 25, 2015, 10:41:01 AM

Previous topic - Next topic


My X68000 Ace died towards the end of last year and failed to boot properly.

I have spent the last day stripping it right down and replacing all the capacitors on the main board, daughter board, riser and even the main logic board for each of the floppy drives.

Put it all back together and it's alive again. However, for some reason the internal expansion ram (PIO-6834-1M) is not being recognised. LHES reports 371K free memory. I removed the expansion and confirmed I get the same 371k free ram. I then replaced the 100mf cap on the expansion, still the same.

Am I right in thinking the X68000 should just see this Ram? There's nothing I need to configure in sram for it?

I worked with my anti-static mat and wrist strap so a zap is unlikely. Unless I'm missing something obvious, it may be I have to reflow the solder for the onboard connector.

Any other ideas? Has anyone had similar experiences with an internal module?


X68000 computers do not auto-detect RAM.  You have to run switch.x from the command prompt and manually set the amount of RAM installed.  Then save and reset, the setting is stored in SRAM.


Thanks! I didn't know about switch.x

I'm such a noooob  :o