X68000 ACE HD - Bluish screen with vertical bars, no indication of operation

Started by lupin3rd, April 15, 2023, 03:37:14 AM

Previous topic - Next topic


I recently picked this machine up as a fixer upper. Out of the gate, it does exhibit some strange behavior.  If I plug it in and switch the PS switch to on (just PS, not front switch) the following happens:

  • PS fan spins
  • The TIMER led on the front is red
  • The Power led is red
  • Machine outputs a bluish screen with jailbars (even while unit is OFF, but PS is switched on)
  • If I press the Power switch on the front, nothing changes with the video

If I turn the PS switch off, of course, the blue screen with jailbars goes away. I'm using a working Sharp Dual Scan monitor, as it outputs video properly with a XVI Compact that I have (different issues with that one, i.e. non-working 3.5" disk drives that like to eject any disk provided).

Seeing all of this, I took the conventional wisdom of starting out by recapping the power supply, just as a jumping off point. In total, these are the things I have done so far, with no changes being evident:

  • Recapped PS, but I think someone else had done it already, as the red caps were not installed
  • Gave PS board a vinegar bath with some gentle scrubbing to neutralize electrolytic fluids/damage
  • Removed the battery on the bottom board, as some minor corrosion was evident
  • Gave the bottom board a vinegar bath
  • Recapped the RGB board
  • Gave the RGB board a vinegar bath
  • Recapped the mainboard
  • Removed the 74ALS05 chip and installed a socket
  • Put the 74ALS05 back in the socket as I don't have a replacement to try yet
  • Tried pressing the Interrupt button during boot, as well as holding the CLR button during boot - neither resulted in any changes

Does anyone have any other suggestions or things I could try next while I'm waiting on a 74ALS05? I don't understand enough about the video generation on this thing to come up with any new ideas.

Appreciate it! Very glad this site/forums exist, as the information here is a treasure trove.


Bottom board causes soft power issues, you need to recap it as well and there may be a few components to change also.  Plenty of info on what to do here if needed.

If the battery leakage has caused traces to be broken you'll be in trouble - loads of Aces with the same issue.  It can leak under the connector to the mainboard and it's extremely hard to clean up, you'll also need to check traces to the IOSC chip.

I have a similar vintage Ace looking at the bodged resistors and caps on the mainboard, after extensive work I've never been able to get it to boot.  I believe the connector between mainboard and sub board has issues, as the behaviour seems to change by wiggling/reconnecting the cable.

If it's a HD model you likely need to stick something on the SASI bus otherwise it won't boot.  You should at least be able to get an error message to appear on screen pushing the interrupt button.


Thanks for the info! If bottom board is related to soft power issues, I'll definitely be finishing the cap kit on that next, since the machine kind of acts like it "turns on" (fans spin, despite OFF status) when the master switch is turned on.

It is an HD model, and does have a SASI drive installed and on the bus. Not sure if the drive is working yet or not, though, but just as a test I tried booting with and without, and nothing seems to change the jailbar output.

Well, I think I at least have a plan to move forward with, I'll post back whatever happens next! Probably won't have a chance to rebuild the bottom board until later this evening, so maybe an update on the post tomorrow. Thanks again, @watto


No worries, best of luck with it.

If you have any more questions do reach out.  Would be great if we can get another one working.


Well, that was disappointing. Was hoping for at least a slight change in behavior after doing a full recap on the bottom board. So that means the whole machine has been recapped, and I'm still getting the same weird video output without any change. I did replace the 74ALS05AN next to the RGB connector on the motherboard. The old one WAS actually bad (it failed on a retro chip tester -- replacement one passed the RCT tests).

What I'm most perplexed about is what is generating the image I'm seeing now? It almost seems like the mainboard is dead, perhaps no clock. It doesn't seem to be watchdogging, as the video image doesn't seem to blink or reset.

It may seem like an obvious thing, but I'm at the point now where I guess I'll have to try to verify more of what is and isn't working. The obstacle to doing that before now is finding a place to set my stuff up where I can lay it all out (connected together) to test it. Looks like my work is still cut out for me.