Forum Updated! 

Main Menu

MO drives for FMT

Started by Cyothevile, February 27, 2022, 01:34:42 PM

Previous topic - Next topic


Lately I have wanted to use an MO drive to primarily experiment with trying to transfer files used in Tsugaru emulator to the FMT. My primary development environment is Tsugaru but I would like to migrate to my HR desktop.

KTJ-san from towns preservation circle was very nice and created a guide on his website.

I used his guide specifically for the MO drive jumper settings. It must be added that "SCSI1" dip switch settings show up the MO drive as "SCSI 0" device in FMT. It appears the disc size limit by townsOS for bootable disc is 230MB.

I can report I have successfully installed TownsOS to an MO disc with the MO drive set to HDD and my HR100 loads TownsOS fine.

Later though I will try KTJ-sans settings so I can use the MO disc with the MO drive set to "MO" on the dipswitches in a USB MO drive and transfer files from windows.

Maybe floppy discs are more practical in transferring EXP files but this old tech seems fun :)


I really like MO disks. I have several drives (SCSI and IDE) for my PCs and X68000s. So I'm indeed very interested to have them working on FM-TOWNS.

I have 3 models:

So I wonder which can be used with a MO drive and how.


MO drives are certainly a technological curiosity. I bought one just to play around with mostly due to memories of them being in Resident Evil series.

Alas they are extremely, extremely slow. If read/write speed was faster they would be a viable alternative to floppies or flash.

Never hooked one up to my Towns PC though. I imagine it should work out of the box. It certainly is simple to hook up to X68000 and PC98.


"Extremely slow"!? Are you sure? you can use them as HDD and they are faster than FDD. Writing is usually twice slower due to the way to record data. I have an IDE MO drive and tried it on my modern laptop using a USB<->IDE and it worked fine and I didn't feel it was that slow. This is an easy way to transfer if you have a SCSI MO drive connected to a X68000 for instance - more easier than FDD.


Well, speed is all relative. Sure, they are certainly faster than floppy drives.

Yesterday I tried to experiment with MO drives on my FM Towns. I have an external USB MO drive, and an external SCSI one. The SCSI one has a single switch that lets me chose it to be SCSI ID 0 or 3.

I have a bunch of 230mb MO disks. In the past I used XM6's excellent MO disk support to make a virtual 230mb X68000 bootable MO disk file, fill it with stuff and then write it to my actual 230mb MO disks via the USB drive, and physically boot from them on my actual via the SCSI MO drive set to ID3.

Anywaste, yesterday I wanted to do the same, so I fired up UNZ and saw that is does not have support for MO disk emulation and creation like XM6. No biggie, I just made another virtual 230 MO disk file using XM6, an unformatted one, and mounted it inside UNZ as an HDD file.

I then booted UNZ off of a mounted image of Towns OS 2.1 L51, then installed Towns to the MO "hdd" file. It all worked fine in the emulator. I thought then I could just write the MO hdd image to my actual MO disk and have my actual Towns machine boot off of it via the external MO SCSI drive, but no dice.

I see the access light of the MO drive flash briefly when Towns reaches the bootable HDD with the SCSI ID set on the SCSI drive, but it just reports the disk to not be bootable.

Somehow even though I posted here I completely forgot about this thread. The links above do indicate to me that my approach is off somehow. My SCSI drive has no jumper settings for MO or super floppy modes though, but I am guessing it is in MO mode since X68000 can boot off of it?

Also, FM Towns needs device drivers to access MO drives then that would mean that it cannot boot off of one, right? Because it would needs to boot off of something else to load the driver first.

In any case, it seems I would need to try and experiment with this on actual hardware. Seems it is not doable via UNZ.


Plz check the link I posted


Already did. My SCSI MO drive (IO data) does not come with a mode switch though. But, since I can boot from it on an X68000 I assume it is by default in HDD mode?

By the way, no matter what I clicked on inside Towns Menu 2.1 L51 I could not find any format or partition utility. Is there a guide on how to do that on a Towns? Maybe that is the step I missed inside UNZ?


Ok, this is strange. It seems I had a FM Towns 120mb .vhd file lying around which someone made and shared somewhere at some point. Have no idea where I got it. It seems to be a custom jobby with DOS 6.22 and Towns MENU on top.

For shits and giggles I wrote the image to an MO disk and to my surprise my UX actually booted it via the SCSI MO drive no problem. Unfortunately that image seems to have very high memory requirements, for reasons that are beyond me. It refuses to boot into Towns MENU on my 2mb machine, complaining about lack of memory.

I fiddled with it a bit but could not figure out how to reduce the memory requirement via autoexec or config.sys edits. Maybe the requirements come from the OS itself?

Anyway, I thought why not try formatting the vhd in UNZ, then install a clean copy of 2.1 L51 and see if it was still bootable, and to my surprise, it was not.

It still boots fine in UNZ though...

So, what is going on here exactly?

Seems I need to have physical CD to install this properly now that I know an Towns OS can be booted off of SCSI MO drive.


Hi kamiboy, glad to see you're experimenting about MO drive with FM-TOWNS.

I recently acquired a Mocking Bird MO 230. The main reason is that drive should share the same model than the internal one you could find on some FM-TOWNS models and to improve chance to have it handled by the OS.

The documentation says:
QuoteDip switch settings

SCSI-ID   0   1   2   3   4   5   6
switch 1 OFF ON  OFF ON  OFF ON  OFF
switch 4 Not used
switch 5 OFF HDD mode / ON MO mode
switch 6 Not used
switch 7 OFF For connection to other models / ON For Apple Macintosh connection
switch 8 OFF For connection to other models/ ON For connection to NEC PC-98 series
switch 9 OFF SCSI-1 mode / ON SCSI-2 mode
switch 10 OFF Internal termination resistor OFF / ON Internal terminal resistance ON

(1) Ranges and restrictions for setting SCSI-ID numbers.
    1) For Fujitsu FM-R and FM-TOWNS, set the SCSI-ID number in the range 0 to 4.
    2) For NEC PC98 series (only when used with MS-DOS), set "1" or more if there is only one MO drive, and if there are other SCSI devices, leave one or more empty (so that they do not become consecutive numbers). If there are other SCSI devices, leave one or more empty (so that they do not become consecutive numbers).
    3) For other model PCs, set the value in the range 0 to 6.

(2) Switch settings.
    1) With both switch 7 and switch 8 in the OFF state, this is for connection to AT-compatible machines, Fujitsu FM-R and FM-TOWNS (*).
    2) With switch 7/ON and switch 8/OFF, for Apple Macintosh connection.
    3) With switch 7/OFF and switch 8/ON, for connection to NEC PC-98 series.
* When connecting to Fujitsu FM-R and FM-TOWNS series, use in MO mode with switch 5/ON. Supported operating systems are MS-DOS ver 5.0 and above and Windows 3.1 only.

I wonder if the 640 version would also work (also acquired) but that's another story.

I believe FM-TOWNS are only SCSI-1 so be sure to check it (but it seems you were able to have yours working with one image you got it).

I thought 2.1 L51 was problematic (something I read somewhere). My UX40 has 10 MB so I guess this image will probably work.

I'm all earring to your further progress.


Well, I got it to work by getting hold of a burned ISO of TOWN OS 2.1 L51. Then I formatted the MO drive and installed TOWNS OS on it just as I would on the emulator, just needed to pick the right installation drive during the installation process.

I can now boot into TOWNS OS directly from the external MO drive. The SCSI ID is set to 0, but I believe it would have worked no matter what I set it too. TLDR, installing it to a virtual drive in en emulator and writing to MO disk does not seem to work, but installing directly to the MO disk on hardware works just fine.

I am starting to be really glad I bought this external MO drive. So far I have successfully managed to boot off it from my FM TOWNS and X68000. Also, I am pretty sure I could use it to transfer files to my PC98, so it is rather useful tool.

I don't see why a 640mb MO wouldn't work. TOWNS seems to only be able to make partitions of max size 120mb, so most of the disk will be wasted. I think there are tools in TOWNS OS to allow for making multiple partitions, but I have not been able to find one. If anyone figures out how it would be nice to know.


Maybe the answer lies somewhere in that quote?
QuoteThe maximum capacity depends on the version of 35MODRV.EXE; DOS6.2L10's can only format up to 128MB. L10+3's can format 230MB.

By the way, I wonder how you manage to boot on the MO without needing a floppy or CD-ROM that sets up access to the MO. If that's the case, maybe it's a 128MB limitation in the BIOS?

QuoteOne partition can be up to 127 MB (but you can use up to 540 MB with EXTDRV, but DOS6 is required for formatting).

This quote was for DOS3. Not sure for DOS6. I fail to find information about EXTDRV so far.

TOWNS DOS3 128 only Drivers such as MO.SYS, SSS, KUMADISK are required
TOWNS DOS6 128-540MB Drivers such as 35MODRV.EXE (Note 3) and KUMADISK are required.

Using KUMADISK should allow up to 540MB while 35MODRV up to 230MB.


I will verify KTJ-san but I believe Towns MO disc limit is 240mb or 230mb.

I'll send him this thread so he can verify how to use larger capacity MO discs.

I was primarily interested in using an MO disk to boot TownsOS and also somehow use USB MO drive on Windows10 and manage the disc contents. However I think this might be impossible.