X68000 Mouse CZ-8NM2A

Started by TheRealAnubis, May 14, 2021, 11:58:44 AM

Previous topic - Next topic


Hi all,

I'm having mouse problems!  I have a Sharp CZ-8NM2A mouse that I got a while back.  I tested it with some graphics program (can't remember now), it was a little twitchy, but worked.  It's been put away in a plastic storage tote until last week.  I've plugged it in and can't get it to work on anything - HumanOS, SX- Window, etc.  It plugs in tight, and has all the pins.

Any troubleshooting tips for these?  This isn't the puck-style mouse- I'll attach a picture.



I don't have this mouse, but here are some debugging tips/ideas:

- Are you experiencing issues only when moving the mouse? Does left/right-clicking works? If the buttons work, it may just need some cleaning.
- Have you tried to plug the mouse on both the keyboard and the X68k itself? According to Inside X68000, the mouse data signal (MSDATA) uses the same route regardless to where the mouse is plugged, but this is not the case for the mouse "control" signal (MSCTRL), which is generated independently by the computer and the keyboards. You may have a problem with your keyboard instead of your mouse.

I haven't been able to find pictures of the inside of the mouse, but you should have 5 wires soldered on it that comes from the cable: VCC, MSCTRL, MSDATA and two GND lines. If you have a multimeter:

- Open the mouse.
- Plug it to your X68k, and start the computer.
- VCC, MSCTRL and MSDATA voltages (relative to GND) should be around 5.0V
- If your multimeter has a "Hz/frequency" mode, or better if you have logic probes, you should see that MSCTRL is pulsating at 1kHz, and MSDATA faster than that.

If you can post pictures of the inside, that would be great.
Hope it helps!



Thanks for the tips!

I'm using a gray keyboard that I fixed recently that doesn't have the mouse plugs on the side - so I'm plugged directly into the Expert.
I get absolutely no response now - it worked a year ago, it went in a box, I got it out - nothing, no clicks or movement registers.  I've checked the wires/connection to the plug and they're all solid, but I haven't checked with a logic probe as I don't have one anymore.

I just got out my black keyboard with the mouse ports on it and the mouse now works!  I guess there's something dead on the bottom board!
Thank you for the idea!  I didn't even think to plug it into the port on the other keyboard.  I still think I had used it in the front port the last time I tried, but at least now I know the mouse works!

Thank you!

Pix attached.


Hopefully it's just a matter of replacing the mini-DIN socket.
Thanks for the pictures.


That's what I'm hoping!

Thanks again!