Forum Updated! 

Main Menu

FDX68 Problems

Started by X-Col, June 06, 2020, 07:52:20 PM

Previous topic - Next topic


I bought the FDX68 a while ago as a kit and recently assembled it.

It works very well but it isn't perfect.

I'm wondering if the emulation software still needs tweaking or I have done something wrong with assembly.

Some examples:
-Both disks being ejected when only one should (Akumajou Dracula ejects both disks when finished loading instead of just disk 0, same with Lagoon when it supposed to just eject disk 0)
-Naious randomly asking to insert disk when it is already inserted, some others do the same
-Ys 2 Ancient Ys Vanished doesn't load (something about disk b in Japanese), it loads if I overclock my X68000 but then the sound is garbled
-Aquales not saving progress

Out of the small number of disks I have tried, a large percentage have issues.

I can't find any info on the web out there with others having these issues, which leads me to believe there is something wrong with my FDX68 unit. I've inspected it closely but everything looks fine (no bridged solder joints etc).

Can anyone share their experience with this floppy emulator?

I would ask Gimons himself but I'm not on Twitter.




First I have trouble to install and configure it. I don't know linux and had to check google even to learn how to do a DIR! But I managed to do it and even installed the FDX68-php that helps a lot since you don't have to deal with linux commands.

I did test only a few games:

Dracula: I remember to have some trouble to have a working user disk saving. I did but don't remember now what!

Naious: Did not have any trouble

Choujin: FDX68-php somehow corrupted disk 2 and the game still reading and running (but without some background graphics). But I solved it creating a new disk 2 (FDX format).

I test a few more but nothing to report.

If you interested in make things easy I recommend you to setup FDX68-php:

also Michael (creator of FDX driver swapper) have a similar solution that I plan to test in future:



thanks for the reply, much appreciated!

As you don't seem to have the same issues I experience with the FDX68, I must assume there is something wrong with my unit. It ejects disk images for no reason and the screen sometimes tells me there is no disk inserted when the emulator software clearly shows a disk image.

I am currently using the command line FDX68 in raspberry Pi 3, and don't have a clue how to get the software you linked to working. But I don't think this is software related.

I've tried the FDX68 with both my ACE and XVI Compact and the same behaviours exhibited :-(

Update: I have just created 2 blank fdx images and formatted them. Tried to copy files from HUMAN.XDF to one of the images and it corrupted the disk - message ' Management area of the disk is corrupted and unusable'. Tried the other image and it got a bit further with copying files but then said disk wasn't inserted, followed by the 'disk corrupted' message when I hit Retry.  ANY IDEAS??



I had indeed trouble with some games, where I was expecting just one disk to be ejected but both are. I recommend you to use FDX68-php because you can ativate real time update and you can see what FDX is doing with each disk (reading, ejecting, etc) and you have a chance to re-insert the disk when wrongly ejected.

About FDX68-php installation it's not a piece of cake (I lost a weekend trying - I'm not Linux's friend) but maybe you are lucky and the automatic scripts works for you:

"We also provide an automatic shell to execute them all together and their description.
Initial settings for Raspberry PI (raspberrypi_setup.txt/
FDX68 for php settings (fdx68php_setup.txt/ "

I recommend you to get a clear sd card and install the correct distribution. I got many errors because I tried with a already configured RaScsi sd card...

Just google translate everything.

About the test you did: Does the error have something related that certain files from Human os should be written in  the right track and sector? Just a thought.


I have been trying for a couple of days now but still haven't got FDX68-PHP to work.

The scripts seemed to go ok, but when I restart nothing happens.

I might try to do it manually instead, but Linux is a foreign operating system to me, unlike DOS.

Did you start from Buster LITE?

About the file copying, it doesn't always happen. When it does it can stop on any file, so seems pretty random. I'm thinking of getting a HxC Floppy emulator instead



If you installed everything sucessfuly, you dont have to do nothing more on raspberry side (expecting add more games - but you can do it using FTP).

Turn on raspberry and after boot sequence you can open a browser window (Chrome, IE, etc) in a computer in the same network as raspberry and digit the IP your router is giving to Raspberry pi. In my case I just digit and receive this screen attached fdx68.jpg.

The second screen (fdx68 2.jpg) you can see I already turned on FDX emulation (2 buttons below text FDX68 on the botton - first turns on and second turns off), checked the option real time update (top) and load Choujin disk 01 and disk 02 in the respective drives (top). That way I only have to turn on X68000.

Let me know if you get it working.


Just a quick update to say the latest FDX68 software release (1.26) seems to have resolved my problems.



Another update regarding the disk ejection problem.

The floppy drives on my ACE HD are now working and they exhibit the exact same problem.

It turns out that it is the FDD-Drive Swapper board that is the cause and not the FDX68.

When the machine sends the eject signal to drive 0, both floppy drives are ejected. Apart from being annoying, it causes problems with some games (i.e. you can't load the second disk of Cho-Jin). I removed the FDD-Drive Swapper and now the drives eject correctly.

If anyone knows how to contact Michael (the creator of the FDD-Drive Swapper), I would appreciate assistance in fixing the problem. His website is here:


Hi X-Col

Michael replied to me in his twitter account (in english). You should try the same:

Let me know the results. I was thinking the disk 2 Choujin was corrupted but maybe the board are ejecting it like you said.

Quote from: hyrulebr on June 10, 2020, 10:54:56 AMChoujin: FDX68-php somehow corrupted disk 2 and the game still reading and running (but without some background graphics). But I solved it creating a new disk 2 (FDX format).


Hi hyrulebr,

the problem I have is that any time software sends an eject signal to drive 0, both drives eject (drives 0 & 1). This also happens when loading physical disks in the floppy drives when the drive swapper is installed (i.e. the switch in internal floppy position)

If I uninstall the drive swapper the floppy drives work correctly. It is nothing to do with images, these are actual floppies and it is not specific to Choujin. If I load Akumajou Dracula, both disks are ejected when the game finishes loading (only floppy drive 0 should be ejected). Again, it works perfectly with the swapper disconnected.

I don't have a Twitter account as I don't really like social media. I have permanently removed the FDD-Drive Swapper as it's too annoying. Shame as it wasn't cheap!

I was hoping there was some simple fix I could apply to resolve the issue?

Thanks for your help! :)