X68000 Pro - D.O.A from Yahoo Auction

Started by megatron-uk, June 17, 2020, 01:50:19 AM

Previous topic - Next topic


All done. Main, sub and floppy/audio riser boards all caps replaced and back into case again.


I'll attack the floppy drives tomorrow night - there's a bit of a heatwave going on in the (normally gloomy) UK at the moment, and I think I deserve a cool bottle of cider after that little lot!


If anyone is interested, I've put together a complete capacitor list (main, sub, audio riser and floppy drive), as well as a complete listing of all IC's and their part numbers on the boards:



(Edit) Have also created pages on the wiki with the same content:
- https://gamesx.com/wiki/doku.php?id=x68000:x68000_pro_capacitor_list
- https://gamesx.com/wiki/doku.php?id=x68000:cz652c_floppy_caps


So after that epic capacitor and audio IC replacement journey, what's the results?

Well, the case speaker and volume control now work decently - you can hear it without having it cranked right up, or putting your ear next to the speaker.

Motos still boots fine, and the image quality is probably a little better than before.

But the keyboard still doesn't work, and it still refuses to boot from a master disk, with the message "It was not possible to start the system, please reboot".


Have been running memtest68k and it's all looking good on the memory side of things, with the iodata 1mb module it detects and checks 2mb total, and with the xsimm10ss fitted and maxed it's detected 12mb total and is checking it now.

I don't think memory is part of any remaining issues.


This is going to be a pain in the ... To track down the keyboard and human68k boot issue. There's obviously some piece of hardware that human68k is checking and refusing to boot because of, but Motos and memtest68k are fine without.


Also, should Motos start and be playable with just a joystick plugged in to port 1 or 2?

I've got an old Quickshot msx joypad and it doesn't appear to do anything plugged in to either port on the machine.

Urgh, looking like this board has way more problems.


I'm starting to feel that I should just walk away from this now. I don't know where to go next and I really don't have the electronics engineering background to get myself a scope and start diagnosing signals on the board.

There's another couple of Pro's up for sale on YAJ at the moment, including a couple that are confirmed working. I'm close to calling this one a lost-cause.


Checked for power at the mouse, keyboard and joystick ports and its there (+5V and some other readings), but that's about the limit of what I can check. I'm officially out of ideas now.

The only thing I can do without buying a scope and putting myself through an electronics course is pick up another Pro and see if I can make one good system out of two. At least if something is confirmed booting all of the peripherals of mine and the first floppy drive should swap over, if needed.


This is some best guessing here and based off the wrong schematic:

Joysticks look like they go to a UPD8255AC-2 which could've died from overvoltage.  You probably want to confirm there's clocks coming from the general IO chip first (because that chip doing anything will likely depend on the 4 or 5MHz clock), which is of course different on the Pro so not even sure that the pins will be the same.  If the IO chip itself was dead I'd expect that disks wouldn't load at all among other things - but it could also be partially working I guess.  Joysticks themselves are super simple, basically just a bunch of switches, at least in MSX/Atari spec.

Mouse and keyboard both go through a few different 74LS type chips.  If they work similarly to the PS/2 protocol, there'll be a clock line that's toggled by the host and the device itself.  The host pulling it low (at least for PS/2) will normally stop the device from sending.  In the case of the X68000 looking at the schematics, I'm guessing this is at least in some way equivalent to the KBREADY and MSCTRL which both seem to be toggled by a couple LS08s.  It looks like they are also both affected by the soft power circuits, so they are something you can check.  I'd expect the keyboard to not do much if that line is stuck low or high or whatever it's meant to be on the X68000.

You don't need to study electronics to get this stuff, assuming you understand binary logic (given you can code I'm guessing you do.)

For checking say a 74LS08 you can grab a data sheet, see what the pins are supposed to do, and then measure the two input pins and then the output pin.  If the output isn't performing correctly, then you know the chip is broken.  An LS08 has 4 AND gates, so if both inputs are high, then the output is high.  Since you know, eg. the keyboard uses 9, 10 and goes to 8, you can check those gates for correct behaviour, and probably rule out that IC as an issue.  A logic probe makes this easy, stick it in TTL mode and look at the little LEDs.

The LS chips are where I'd look first, following the schematics - you go in order from cheapest/most easily obtainable to horrifying/they stopped making those in 1997.  At least that's my method :P

You can at least check for voltage, you can also kind of hackily check for oscillation using a multimeter in AC voltage mode, but it probably won't work well or maybe at all and isn't really conclusive.  Need to be real careful not to short anything while doing that also.

This may all be entirely fruitless of course, and there appears to be a data line that's shared between a bunch of different things, and ultimately ends at the IO chip.  I can understand why you'd be reluctant to go down that road.  Having some more equipment can help, but it doesn't always.  I'd not rule out a scope - for the X68000 you can probably get a cheap second hand one at 20MHz, but at minimum 50MHz is probably more useful in general.  Scopes have a learning curve though unfortunately, so it's not necessarily going to be that useful to you unless you want to do this sort of thing more often.

I should also mention I do have a junk Pro heading towards me too at some point, and depending on how junk it is I may be able to do some measurements for you, etc. if that can help out.


Yes Motos should start whiel pressing the button and you can play it without Keayboard and mouse.

One idea could be checking (replace) the NEC 8255 IO Chip. this controls the joypad ports.
But i don´t know if it has something to do with keyboard and mouse.

one time, i got a quicshot joyboard with 2 cables (i think for C64 Port 1&2) and i can switch to Amstrad, MSX oder Atari.
I used that board the same time one cable plugged in my Amiga the other in the X68000 and no problems.
But then i got the XVI and i used (to test Star Wars on 10/16Mhz) the board on both X68000 machines.

With that i blow that NEC IO Chip on both X68000. One got direction problems the othe didn´t do anything.
Replacing the chip fixed it.

Perhaps it is blown because of your voltage fault ? Maybe some more chips are blown.


any, hopefully good news ?
Or did you throw all out of the window ?


Ha! No I didn't throw it away, but I do have another Pro coming from Buyee that is working, at least to the point where it boots human68k and plays games.

At the very least I know I have a working PSU setup now, and a fully working drive 0 and peripherals.

Life is too short and my free time too valuable to continue on trying to diagnose this one, so I'm cutting my losses.


I appear to have a somewhat working Pro now (it boots stuff at least) if you change your mind about trying to fix yours up - can at least grab some measurements and follow accurate traces to tell you where to look.  Haven't tested everything yet though, some pretty dodgy looking caps around the place and some rust, etc.  Looking much better than my ACE anyway.


The two 6.8uF caps on the floppy board (C23, C25) appear to be bi-polar.  This doesn't seem to be noted anywhere.

I'll keep any eye out for others.


 I have to admit I didn't get around to replacing all the caps on the floppies when I found that I still had keyboard issues. Thanks for the correction on the two bipolars.. looking at my closeups of the drive boards now it's clear they don't have polarity marks on the PCB for those.


All done with mine apart from floppies as I'll hold off on those til I do another Farnell/Mouser order.  They are both working and had a head clean and rail grease.

Nothing new I found on the two main boards of note, thanks for those lists you made as I did get distracted a couple times and forgot what I'd removed from where.

In the end there was a bit of cap leakage around but nothing too major.  This mostly manifested in solder that didn't seem to flow well on top of the board and some residue around that needed cleaning up.  I'd managed to lift a pad/trace when pulling out a cap near the soft power circuit which prevented it from powering on, didn't even notice I'd done it.  Fairly easy fix with some magnet wire at least.

Still waiting on a keyboard to confirm everything (should be a couple days away), Motos at least looks good so far, joystick, sound, video, both drives work perfectly.  Got a SCSI2SD and some RAM to add to it, should end up being a nice system hopefully.

I was hoping to mount the PicoPSU and adapter board within the old PSU case, but it's a bit skinny with that and the fan still in, the old power cables are a bit short too.  Will see what I can figure out, may end up creating a new board to suit the Pro if I can find some more cheap ones.

The ACE has some stuff incoming, so hopefully that can be revived too.

Curious how you get on with your new Pro, let us know if you run into any trouble.


I can certainly understand the sentiment of cutting ones losses. I spent too much time and money working on two dead X68000. Both were hopeless cases with impossible to diagnose faults. Black screens on boot, with the occasional error screen if I Used my fingers to mess around with certain IC's.
Some days I think about going back to diagnosing the one I still have in my possession, but then I remember all the work I already did and give up.


My second X68000 Pro finally turned up today - it took 2 days for Buyee to process it, raise charges and send it on, then just 4 days go around the world and get through UK customs.

The parcel then sat in my local delivery depot for almost 2 weeks without anyone getting in contact to pay the import fees. I had to pester on Facebook and on their 'account holder' phone number (even though I don't have one) to be able to pay the fees and have it released.

Anyway, I'll get it opened up today and see what I'm dealing with - I'll probably end up with a frankenstein of the two systems; I know the first one now has a fully working PicoPSU system and a solid floppy drive 0, as well as quite clean case and chassis. The second one has a working drive 0, sound, video and keyboard/joystick input, but doesn't always start up.

I'm hoping I can transplant one of the drives and re-jumper it as drive 1, as well as swap one or more of the boards and get a working system (I'll try replacing the board with the IO controllers first).


.... and it has an absolutely horrendous leak from the battery, which appears to have eaten major sections of the IO board:


I'm never going to catch a break with this thing, am I?


Quote from: megatron-uk on September 15, 2020, 09:02:23 PMThe parcel then sat in my local delivery depot for almost 2 weeks without anyone getting in contact to pay the import fees. I had to pester on Facebook and on their 'account holder' phone number (even though I don't have one) to be able to pay the fees and have it released.

Was it Parcelforce?  Most of the time I end up calling them to get the reference number for paying the customs fees.  Worst one I had the letter arrive about two weeks after I paid it.

Did it have a barrel battery in it?  Either I've been mostly lucky or there's some variation between models.  The last couple machines I've had now have had a lithium battery on them which is dead but hasn't leaked.

There's a fairly large ground in that area, quite a lot of stuff is connected on the other side.  Worth giving it a clean at least to see how bad it is.


Yep. Parcel farce.

This one had a NiCd barrel battery. Snipped it off as soon as I saw it. The battery traces have continuity, but there's loads of tiny traces and visa to check.

Interesting that this is an earlier revision and there are some slight differences to my original system:

Cynthia chip is plastic topped PGA on my original, it's a ceramic PGA on the new one.

There's a weird resistor bodge on r70 on the new board (two resistors in parallel)

There's a huge cap near the video output stage in the new one that appears to have one leg soldered to a 74 series logic if next to the video out.

Both the above bodges appear factory.

So far the new boards haven't gotten me any further:

Old main board and new io board: no soft power, no video out
New io board and new main board: no soft power, no video out
New main board and old io board: soft power and "insert floppy" message.

I need to hook the floppy drives back and test the last combo, but in none of the above did the keyboard light up.


So both floppy drives now work (using drive 0 from the 'new' machine and drive 0 from the 'old').

Both drives will boot and play Motos.

Using the "new" motherboard and my "old" IO board I get sound and video (flickery, so the "new" mainboard clearly needs a recap).... but still no keyboard. So in that respect, it's no advantage over my recapped "old" one.

The only thing I can think of doing now is to use the "new", corroded IO board, desolder all of the IC's and fit them to the "old" one.

As of now, I'm ahead by one working floppy drive with this system... but still no working IO.


Set of DIP sockets ordered - I've got them for everything except the two 42-pin Sharp IC's (DISCO and DISCO-II).

I'll probably start with the 74-series components near the back of the board, as they seem to comprise the logic devices for IO, as well as the Z8530A chip which seems to have something to do with keyboard and serial IO. The FDD controller most likely doesn't need changing, as the system boots and plays from both disk drives fine now, I also know that the audio section is 100% as all the components and IC's have been changed (except the OKI DAC).


Got half the components removed from the corroded 'new' board so far. DIP sockets are on the way, so I'll get the remainder of the chips removed and then start taking the chips off the 'old' board.


At least I'll have plenty of components to go through and check. Fingers crossed this does it. The only other thing left to do on the IO board is to replace all of the remaining passive components.


Donor board now completely depopulated:


No, I'm not taking the two surface mount chips off. I don't really have anything to do that properly.. the last time I did any smt stuff was probably 15 years ago and my eyesight and hands are not as good any more!

Only broke one trace taking everything off, so I know what to expect when I tackle my 'original' board next and remove the components ready to fit the sockets.


I've transplanted all of the IC's from the new corroded board to the original one that was subject to the power issues, except:

- The OKI DAC (smt)
- The IOSC chip (smt)
- The DISCO-I and DISCO-II (fine pitch DIP, which I don't have sockets for)

Behaviour is exactly the same as before:

- No keyboard (no lights, no input detected in Motos)
- No joystick (no input detected in Motos)
- Human68k won't boot ("It was not possible to start the system. Please restart")

The same behaviour is now observed on both main boards (my original, power-spike one, and the partner of this new corroded io board).

I'm extremely wary about trying to do anything with the IOSC chip, but I'm coming to the conclusion that it's either that, or the two DISCO chips that are at fault. However, without a diagram like the other models, it's extremely difficult to be sure.


did you wrote before that no Joystick inputs are detectet ?
You should chek the 8522 IC. This is the programable I/O Chip.
This one was blown on my both X68000 when i used a quickshot joystick with 2 cords on both X68k at the same time.
So Check this Chip, on mine it was an NEC8255.
And Check the Powerplug to the Boards again. On mine there was a Contact weak

And what about the MC68901 where the traces from the Keyboard goes ?


No joystick
No keyboard
Won't boot a Human68k boot floppy (but will start [and play the attract mode of] a self-booter like Motos)

I've swapped both the 8255 and MC68901 (as well as the Z8530A) with those from the new board, as they all seem to be involved in either joystick or mouse/keyboard input in some fashion.

In fact, I've swapped every single component, except the DAC, IOSC and the two DISCO chips. The only ones I reused on the new board where those closest to the battery leak, as they were slightly discoloured. The behaviour is exactly the same as with the original IO/sub board and chips. This leads me to believe that it's either one or more of the chips that I haven't yet swapped... or it's one or more of the passive components on the board.

The reason Human68k won't boot (but Motos will) must be down to the fact that it is check for the presence of the keyboard controller or something along those lines.


Reset held on the 8255A (should be CMOS level) or maybe a clock issue?  I wouldn't be willing to go any further without confirming the clocks are all present at least.  Lifting the IOSC for example is doable but you'll want to invest in some good flux and I'm not sure you have any hot air equipment.  Takes some practice and patience and it may not even be the cause of your issue.

eg. MC68901 (which deals with keyboard input among other things) will be driven by 4MHz most likely, but that is also related to the YM2151 so you'd expect sound issues too - may be an interrupt being held somewhere, no DTACK, etc.

Going to be a tough one unfortunately.


Yeah, I'm starting to run out of options here.

I don't have a scope nor hot-air rework tools. I can see that there are options for cheap hand-held scopes for just £20-£30 though.


I'm seeing the Hantek 6022BL for about £55, it's a USB logic probe/oscilloscope with up to 20MHz bandwidth. I like it because I can plug it straight in to the PC next to my build area and just use the onscreen functions, rather than have another box on the desk.


Is that sufficient to get a look at the clock signals on the X68k?


The clock can outputs 40Mhz signal, but you will probably be able to see the derived clocks.

Logic analyzer is just fast enough to see the digital signals.


It'll be good enough for what you're wanting to use it for I'm guessing.  The signals you'll be looking for will be 4MHz, 5MHz and 10MHz as far as I can tell. 

For actual practical purposes there's the five times rule - you want a scope than can handle minimally 5x the max frequency you intend to measure.  Since you're wanting to confirm frequencies are there, not analyse the actual waveforms, it should be good enough.  If you later want to use it for more complicated work, it probably won't be good enough.  The logic analyser part of it might be good for other hobby work, the 2 channel oscilloscope part looks to be 20MHz.

I come from an old school of electronics, over 20 years ago, and my digital oscilloscope confuses the hell out of me :P  I can't imagine trying to work it on a PC.


Thanks for the feedback guys; rather than pour loads more money in to this I'll pick up that cheap Hantek scope/analyser and see what I can find.


Oscilloscope/logic probe arrived yesterday, so my task for the weekend is to figure out how it works and try to decide where I need to check on the x68k pro.

Any tips?


When I did the same on my dead machine I started with testing frequencies generated by all crystals, and clock of each memory module.

Also check that the input voltages are stable, not containing any ripples.

In the end I didn't really help me figure out what was wrong with my machines.

If you want to get really advanced you could use logic analyzers to step through the code being executed by the CPU. That stuff was way above my level of capability, or dedication. But it can be useful to see what the CPU is actually doing when you get unexpected behavior.


Ok, sounds like a sensible way to start. Just got the device plugged in, the software installed (https://github.com/OpenHantek/OpenHantek6022) and the test signal connection seems to show it as working. All seems well.

I'm in the middle of desoldering the two DISCO chips - the last DIP components on the board, so once I've got those swapped with the ones from the newer, corroded board, I'll connect everything back up and try testing the various signals on the IO board. Not having the schematics for the Pro is still a major pain in the rear though.


Damn. Put the disco chips in dip sockets and now the thing won't power on any more: no red standby led, just flashing green and pressing the power doesn't give any video.

About ready to throw the whole lot in the bin to be honest!!!


Flashing green sounds familiar. Is it constantly resetting, perhaps?

The X68000 does that when it is shutting down, so it might be related to the soft power on/off circuit. Maybe you could circumvent those and force to power on.


Finally got round to picking this up again. I have since invested in a hot air rework station and have successfully removed PLCC 80286 processors from a couple of PC motherboards, so thought I would give this a go.

As a reminder, the only chips left on the IO board that haven't been replaced are the DAC and the IOSC - which is, funnily enough, responsible for floppy control and general IO port control and selection. It's also the one closest to those caps which blew when the incorrect power supply was fed in.

Removing the older IOSC from the donor (88 date):


Soldering on to the newer, non-battery damaged board:


Cleaned up:


I'm not ashamed to admit that this is right at the limit of my ability. I wouldn't normally try to tackle something as small as this (my eyesight isn't as good as it used to be, nor are my hands as steady), but it wasn't working anyway, so there was nothing to lose.

The change is that the system does now power on reliably, the standby and power-on light works consistently.... but.... now the floppy drives are completely dead. No seek at start, no motor, no soft insert or powered eject, nothing. I just get the 'insert floppy' on-screen message.

I've either killed the IOSC in the process of removing it, or I've got a solder bridge or short between pins somewhere.


Rechecked continuity of the IOSC chip - I'm nearly 100% certain that I haven't bridged anything.

Since the Disco chips are involved in the floppy control I had an idea to swap them back to the original (89-date coded) chips from this machine, rather than those (88-data coded) from the donor.....


It works!!!!

Sadly that only fixed one of the remaining problems - booting Human68k, which it has never been able to do. It always showed that "Error, please reboot".

It still does not respond to keyboard (via PS/2 adapter from Edu Arana) or (MSX) joystick input. So it's still effectively unusable.