Henkan Banchou 変換番長 Pro with CZ-600CE

Started by Turbolenza, March 26, 2020, 12:02:55 AM

Previous topic - Next topic


Hello from Singapore !
This is my first message here. Nice to meet you.

My setup :
The CZ-600CE is the first x68000 released in 1987
I have added 1 MB memory extension, from Beep.
I have replaced the SRAM battery
I have installed a picoPSU, from Beep.
I have a Masterdisk purchased from MSX Repro.

Now, the troublemaker is the Henkan Banchou pro, purchase in shop in Osaka in January this year.

The google translated manual is here :

From what I understand, I can just place a hds or hdf file into the Compact Flash. Unlike the SCSI2SD adapter, there is no need to use WinImage to write on the CF. However, i need to « name » the file with some parameters. [SASI0] [LUN0] [256].

The adapter is connected via the external centronics port.

The adaptor is simply not detected and will not boot Eidi's HDD Image V4.

It's quite difficult to find information online about this adapter... any help will be greatly appreciated.
stay safe.


Don´t know about sasi devices, if the image will work as sasi.
But what if you use scsi and install the driver via bootset ?
And do you use switch.x to setup boot device ?
Is the image (c:) there if you boot with masterdisk ? Then try pressing help on power up the machine


the eidis image is too big for SASI. You will need to install the SxSI drivers.


hi Turbolenza
You have to use winimage to mount the .hdf image
And yes as famiac wrote insert a boot disk with SxSI driver to install them. One time, they will be stored after if your bios battery is good

i have this device but using it with a scsi card

good luck


Dear all,

I have installed the SxCI driver

No matter what i do, i get this when i attempt to boot :

@mez, you have the henkan banchou pro? When i use WinImage to "write" the file, the adapter data access LED is giving an error. However, when i copy X68000 StartUpDisk [sasi0] [lun0] [256].HDS directly on the CF, the LED is no longer giving error.



i have this model, don't know if its PRO or not sorry, but its Classic PC/BEEP SHOP hardware
mounted externaly on scsi card has said before

after installing SxSI are you able to access SWITCH.X to see your configuration ?


this may be related to the settings of the henkan banchou itself


Thank you for your answers. I actually figured out but I still have questions.

@mez, you have the previous version of the Henkan Banchou, with the dip switches, allowing you to do settings. The "pro" version has no dip switches.

Basically, i have downloaded an image file creator, from the website.


It creates "empty" image files using a specific naming convention, that will be "detected" by the henkan banchou pro. Example :


It is finally detected in SCSIFORMAT :

Initialization & format are successful. CONFIG.SYS seems to be successfully transferred as well.

Now, for some reasons, I am unable to make the volume recognized as "C" drive. When launching DRIVE.X, there is no C Drive...


Stay Safe


Update : I managed to change the file configuration and finally the "map" function works, i have a C drive.

I could write Eidis image disk V4 on the CF and launch some games. However, it will not boot from C:.
In switch, i have tried STD and RAM ED0100 & ROM ED0100..


Try on Powerup or reset press HELP key and select HumanOS as boot drive.


Thank you Jehuty. I do not have such option as this is the very first generation of X68000..


I have the same Modell and i have this option by pressing help key.
But i forgot that you use SASI. I use a system sacom SCSI Board.
Thought the option is on sasi the same.


Quote from: Turbolenza on April 04, 2020, 12:33:29 PMUpdate : I managed to change the file configuration and finally the "map" function works, i have a C drive.

I could write Eidis image disk V4 on the CF and launch some games. However, it will not boot from C:.
In switch, i have tried STD and RAM ED0100 & ROM ED0100..

Hi I have here two devices, a SD2SCSI and a RaScsi and both boot to A. Different from western computers, X68000 boot HD will always be A drive and the floppies will B and C if you have just one HD drive or the two next letters after all the HD drives (i use 6 drives in my RaSCSI and both floppies are the last letters).


Thank you hyrulebr for checking on my topic!

I've noticed something wrong : i format the CF (fat 32) and write Eidis image V4.
I can boot from floppy B (A drive is not working well), and the CF is detected as C: right away.
I'm able to launch games & app.. however, if I hard or soft reboot, the CF (C:) is not detected anymore until I put it back in Windows 10, format again and re-write the V4 image.
Looks like each attempt is a "single" use.

Could it be due to bad CF?


I suppose...just check the card and replace it!


Hi, I also have a Henkan Banchou Pro but I use it with my CZ-602C (Expert) and I had also some trial and error with naming the image files right until the thing eventually worked, by just using [SCSI1] to [SCSI3] in the filename eg. `X68000 V4[SCSI1].HDS`, `X68000 MDX[SCSI2].HDS` and `X68000 MiniV2[SCSI3].HDS`.


Thanks PHD... not working better.
I have tested with different CFs as well...


I was has having a similar problem where I could access my scsi cf drive from command after booting with the master disk but I couldn't get my X68000 Expert HD to boot from the cf drive. The solution that worked for me was running "sxsiformat" from the master disk. Than selecting "Bootflags" > input the number 15 and hit enter. Once again select "Bootflags" and input the number of your drive (I used 1), than select end and restart. 


Also I have been using HDD Raw Copy Tool to write my image to my CF drive. https://hddguru.com/software/HDD-Raw-Copy-Tool

You just select the source which is the .HDS file and than you press continue. Select your CF drive in the destination list and press continue > Press Start.


Hello guys, I found this topic while searching help for my Henkan card, I have the external version.

Long story short, on SASI machines the bus power will not work, so always use external power (micro usb), and install the terminator resistors if these were not factory installed. The bus power switch will do nothing on SASI machines, this is normal, so leave it off. Format the CF as FAT32 and put your HDS inside, rename something as "HARD_DISK[SCSI3].HDS" and setup X68000 with Master Disk, installing the SXSI driver first and then setup with SWITCH to boot as "STD" (floppy first). Connect everything before turning ON the X68k, make sure the status leds on the Henkan are lit, and show no errors (check manual). Then turn ON the X68k, should boot from HDD now.

This worked great for me, at first I had problems with the HDS naming until I set it up the same I did with SCSI2SD settings, using SCSI3.

So maybe this extra info helps someone else dealing with these new cards!
From Mexico City... Amigo-Mexicano!
Also known as: "compil3r" || video-juegos.com


Been using BlueSCSI with the X68000 and finally bought one of these. Can anyone vouch for the performance on these guys, any loading issues on the V4 image?


Finally installed it into my computer, it's working like a dream so far.


    In order to help someone with X68000 XVI what is working for me is for 変換番長 Henkan Bancho Pro:

    NOTICE; Henkan Bancho IS NOT a PHYSICAL DRIVE. IS AN EMULATOR BOARD, Henkan Bancho Pro ONLY READ IMAGES as *.hdi, *.hds...
    You cannot Flash CF as usual (With Winimage, Win32DiskImager...).  It will not work
    Is easiest; simply format CF and copy paste images UNDER WINDOWS/MAC ENVIROMENT.

    • Format CF (FAT32 - Complete format NOT QUICK FORMAT) Select 8192 bytes as assignation unit size.
    • Change the original name of V4 Image to "X68000_V4[scsi2][512].hds" and copy/paste image to CF
    • Place the CF in Henkan Bancho Pro and restart computer with Human 68K Ver.3.02 2HD from FDD Disk in drive 0.
    • Execute Switch.X and change BOOT value to STD and SCSI ID to SCSI2
    • Restart

    Now is working perfectly.

    I have got the values from BOOT and SCSI ID after several trial/error process. Maybe you need to try several times depending on your hardware. Do not touch other values you can corrupt SRAM

    Real X68000 is slower than modern emulators loading software, be patient.
    Hope this helps someone.