X6800 super hd and scsi2sd boot problem

Started by aeguimaraes, October 09, 2019, 05:53:33 AM

Previous topic - Next topic


Hi everybody

I need help...

I have a super hd with scsi2sd connected internally (before it I had a hd scsi in the same place working) and the x68 does not access the scsi2sd appearing the drive access screen (that with the floppy icon)

I do not have floppy diskso I can not access the config.

I tried to press reset and nothing happened

I tried to take off the battery and nothing...

The scsi2sd config is ok and i tried diferend sd card 1 and 8 gb and all scsi ids and did not work.

What can I do? Sugestions?

Before, when I was using the hd the system was configures to press reset to access the hd (at the floppy screen) and was working fine).  But my hd stop working...


I am using scsi2sd 5.1 firmware 4.8.03 on a X68000 Super HD


Did you try the scsi IDs before or after you take off the battery ?
I think you have to tell your X68 from what to boot via switch.x, but as long you have no access to a working floppy you seem to stuck.


Yes Jehut. This was the problem. Thank you for your help.

Now it is solved. I used a disk with human os, executed switch.x and changed the boot to scsi 3 and now it is working.

But I have another question, i am using a cdrom externally with id2 set and when I use cdrom.x I can ready the cd normally. But when I use susie.x I can mount but I can not read the cd (error Abort Retry And Ignote). I am using a x68 super hd scsi with scsi cdrom id 2 (i have tried another ids).

Anybody know how to solve this problem?

Ps: the problem is not the scsi2sd, I tried without scsi2sd (only cdrom) and boot from a human os disk drive A.


Don´t know this problem, i´m using cdrom.x and susie.x without problems.
My setup is an XVI, Aztec Monster CF Card as HDD in ID0 and a external DVD-Rom (Pioneer Slot in) on ID2.

Made a bat file with "susie.x -id2 Z:" and it works.

Try the ID0 in the scsi2sd. And don´t forget to switch the boot id.

You can also try "STD" as bootdevice and hook "Help" key on boot to select your HDD. After that it should boot from hdd when no Floppy is inserted, otherwise it will boot from floppy.


Answered in the other threat, could you check the Termination ?
Internal in your super. The XVI has a fuse on the scsi board internally, check if the super has this too.