August 24, 2019, 09:17:38 pm

News:

Upload your images to this forum!.  The internet can't be trusted.  NFG can.  (probably)


SD2SCSI v5 inside x68000 XVI, having startup issues

Started by DMR, October 29, 2018, 03:31:37 am

Previous topic - Next topic

DMR

So I have an original XVI HD power and ribbon cable along with the hard-drive and bracket.

That worked fine on my regular XVI when I installed them.

So I decided to get an SD2SCSI v5 to replace the hard-drive while keeping everything else,
but I have run into issues.



If I boot the XVI, the SD2SCSI flashes, but nothing happens.

But, if I connect the SD2SCSI to a microusb cable, boot the XVI, everything works fine.
I can even unplug the cable, and the SD2SCSI works fine (so it's getting power) (until I do a full shutdown again).

My theory is that it looks like the SD2SCSI is not powering on fast enough,
but if that's the case, how do I get around this if I want this to be internal?
I don't want to have to hack-in usb power to it!

The SD2SCSI firmware is up to date as of one week ago.

The other questions I have are:
1 - What screws + bolts do you folks suggest to mount the SD2SCSI to the original bracket?

I'm referring to these screws though the image is of another device (that I don't own),
just using image for illustrative purposes:


2 - The HD BUSY status light seems to be always lit red - even if I powered things on correctly with a micro-usb cable. What would I need to attach / change for it to reflect the actual status of the HD ?

3 - The original hard-drive had a grounding cable ... do I need to attach this to the SD2SCSI anywhere?
(I assume no since getting it off the original HD looks to be a pain in the tush...)

famiac

You should be able to power the device just from the bus. Try disconnecting the power cables and seeing what happens

DMR

So I've disconnected the power cables and the only thing that's connected is the ribbon cable,
but the same thing happens - doesn't boot - just stuck on a black screen.

I've waited a minute and it seems stuck.

I've found that I can press the reset button (after powering on and entering stuck mode) and it'll resume normally.
It's pointing to it being a timing thing.
Though I rather not have to turn it on, then press reset every time to get it to work properly ...

Anyone else get this same model working internally with no problem?

hyrulebr

Did you set the SCSI2SD to the ID3 using the windows program?

DMR

Yes. Here are the settings:
General settings:


First device settings (the only active device):


And here are my SwitchX settings:

famiac

Ah yes, I've had this problem for a long time now, especially on newer model X680x0's. The only remedy i've found is hitting the reset button, and yes, it's likely to be a timing issue. The scsi2sd is open source, i believe, but I'm fine just hitting reset for now.

DMR

So I’ve contacted the creator of the device (who is active and easy to get a hold of)!

Turns out the x86k doesn’t follow the SCSI standard to allow devices 10 seconds to start up.
SD2SCSI v5 uses the first 2 seconds to check if there’s a firmware upgrade.

The creator had provided tools to flash a new bootloader that would remove this 2 second wait,
but if you flashed a bad firmware thereafter or I assume if the bootloader itself was a bad flash, you couldn’t recover it, which lead to a lot of bricks.
So he discontinued providing support for this.

The issue is fixed in SD2SCSI v5.1 and up, where a jumper pin is used to enter the recovery bootloader.

I’m probably just going to get a SD2SCSI v5.1, and use the v5 for something else.
But yeah, from here on out it should be noted v5.1 and up should be used for the 68k

famiac

November 04, 2018, 03:43:08 pm #7 Last Edit: November 04, 2018, 03:46:58 pm by famiac
Thanks for contacting the creator. Do you happen to know how to fix the issue on V5 models? I'm not worried about bricking

TortoiseFire

November 04, 2018, 05:32:43 pm #8 Last Edit: November 04, 2018, 05:36:00 pm by TortoiseFire
Quote from: DMR on October 30, 2018, 01:03:06 pm
Yes. Here are the settings:


First device settings (the only active device):




maybe someone can help me here, I am a bit confused about Sector count and Device size, does this have to match the size of the SD card you are using or the image file you are writing to it? I noticed in the guide by Leonk the sector count is 2048000 and it doesn't mention to use the device size.  That is for the X68000_V4.HDS image. 

Also isn't your size of 7.25GB too large for the X68000 to handle?

btw I too fell victim and bought the 5.0 device a couple of weeks ago before finding out about this issue. I have ordered a 5.1 device from Amiga Kit.

@famiac and anyone with the 5.0 wanting to try and use it you have to contact the author (the email should be on the scsi2sd board) and ask him for a custom bootloader called "USB_Bootloader-V5_nodelay.bin" and a custom scsi2sd.exe that can write a new bootloader.  The newest scsi2sd.exe doesn't have that option.


DMR

The screw holes are totally different for v5.1.

So I decided to risk breaking my v5. Thankfully it went smoothly, and it works like a charm.

Disclaimer: The following can damage your device.
So much so, that the author himself tried to delete all traces of it.
Any damage incurred is your sole responsibility,
and not of mine,
nor of the author of the firmware/software,
nor of the hardware manufacturer.
To prove you've read the disclaimer, change the word "USA" in the link to "USB" for it to work.


I've found the firmware, backed up by archive.org:
https://web.archive.org/web/20170314181434/http://www.codesrc.com/files/scsi2sd/latest/bootloader/USA_Bootloader-V5_nodelay.bin

And using an older version from the author's site, such as, will have the bootloader upgrade option:
http://www.codesrc.com/files/scsi2sd/v4.6/