July 22, 2019, 06:06:22 am

News:

Upload your images to this forum!.  The internet can't be trusted.  NFG can.  (probably)


Dead sega 32x help,

Started by Geezeratwork, October 03, 2018, 04:34:42 am

Previous topic - Next topic

Geezeratwork

Hi all

Thought I'd have a go on my 32x (was working fine, been stored for a while) and it seems to have died, connected to a megadrive 1 and get no display at all,
Thought maybe an issue with the megadrive so connected to a megadrive 2 but the megadrive powers off when the 32x is connected, tested both megadrives and they work fine, have multiple cables and power supply's but get nothing.

Megadrive 1 with 32x connected powers on but no display at all or sound

Megadrive 2 won't even power on with the 32x connected.

Any help would be great.

Thanks

kendrick

The lack of display tells me that maybe there's an issue with the video patch cable? When you had it connected to the original Megadrive 1,you obviously needed both the patch cable and the big five-pin DIN adapter. Any evidence of bent pins or a bad connection?

Geezeratwork

Hi, the 32x now starts but does not get past the license screen, this happens with both megadrive and 32x games on both the megadrive 1 and 2

kendrick

So the license screen being displayed, and then being followed by nothing, is typically symptomatic of a failure of the TMSS check. This isn't an indication that your 32x is a bootleg unit or anything, but that the contacts related to the copyright check are dirty or otherwise not reliably readable. So in your shoes, my next step is a good, thorough cleaning of all the card and slot contacts between the Megadrive and the 32x unit. That means a rubber pencil eraser on the 32x side, and then the usual dry insert cleaning for the slot on the Megadrive. I bet you it's probably necessary to clean the slot on the 32x as well, and the cart contacts on whatever game you're trying to run, just to be thorough. Let us know what happens after you do all that.

Geezeratwork

Hi, spent hours cleaning every single contact point on the 32x and both my megadrive 1 and 2, gave a few test games a clean too and still won't go past the license screen

Geezeratwork

Thought I'd try a 32x cd game, it loads to the sega sonic screen then black >:(

kendrick

Okay, time for a number of other diagnostic thoughts. I assume the following:

* The Megadrive 1 runs normal cartridges and Virtua Racing with no issues.
* The Megadrive 2 runs normal cartridges and Virtua Racing with no issues.
* The amperage on the 32x power supply is up to spec.

The reason for using a Virtua Racing cart is because some Megadrives aren't compatible with the extra video processing tech in the 32x, and being able to operate the SVP chip in Virtual Racing is an indicator of compatibility.

So then. If those three things are true, then we're looking at individual component failure inside the 32x unit, and that's not something I can diagnose remotely. If I recall correctly, the 32x has about 14 or 15 capacitors on its board, and I'd start my investigation with those items to see if any of them have burst or otherwise failed. Good luck.

Geezeratwork

I'll pick up a va racing cart and check capaticors, thanks for your help

Segasonicfan

There are some compatibility issues between Genesis and 32x that are starting to be more documented. I made a video on YouTube about it as well.  I believe VA4- VA6 can have these symptoms as well as MD2 VA0.  There are issues with the 68k clock signal to the 32x, as well as termination problem on the address bus. Sega tried to fix it with a add on that plugs into the expansion port of the Genesis.