July 18, 2019, 01:26:06 pm

News:

Upload your images to this forum!.  The internet can't be trusted.  NFG can.  (probably)


RaSCSI :) stuck in set up proceedure, please help ???

Started by Ex68Kay, April 28, 2019, 10:34:21 am

Previous topic - Next topic

Ex68Kay

I am stuck at end of Step 4 http://www.mushagaeshi.com/2018/02/24/howto-setup-rascsi-scsi-device-emulator/ 
I need to create an HDS image and load it into the Raspian OS command

I should receive something like:
SCSI Target Emulator RaSCSI (* ^ .. ^ *) version 1.43
Powered by XM6 TypeG Technology / Copyright (C) 2016-2019 GIMONS
Connect type: GAMERnium.com version
---------------------------------------------------------
ID | TYPE | DEVICE STATUS
---------------------------------------------------------
0 | SCHD | x68000scsi0.hds
--------------------------------------------------- -------

I only received an error message saying it couldnt open the file and this:
Error : File open error [X68000_V4gb.hds]
SCSI Target Emulator RaSCSI(*^..^*) version 1.44(Mar 22 2019, 11:30:16)
Powered by XM6 TypeG Technology / Copyright (C) 2016-2019 GIMONS
Connect type : AIBOM PRODUCTS version


***edit: Welp -- got past this 'hurdle.' It worked fine on the Pi itself, in the tutorial I followed it said to enter these commands through the stfp software from a windows computer because "Raspian is awkward"... I received this as I should have:
pi@RaSCSI:~ $ cd /home/pi/Documents/rascsi144p1/bin/raspberrypi
pi@RaSCSI:~/Documents/rascsi144p1/bin/raspberrypi $ tar xvzf rascsi.tar.gz
standard/
standard/rasctl
standard/rascsi
standard/rasdump
fullspec/
fullspec/rasctl
fullspec/rascsi
fullspec/rasdump
aibom/
aibom/rasctl
aibom/rascsi
aibom/rasdump
gamernium/
gamernium/rasctl
gamernium/rascsi
gamernium/rasdump
pi@RaSCSI:~/Documents/rascsi144p1/bin/raspberrypi $ sudo aibom/rascsi -ID0 X68000_V4.HDS
SCSI Target Emulator RaSCSI(*^..^*) version 1.44(Mar 22 2019, 11:30:16)
Powered by XM6 TypeG Technology / Copyright (C) 2016-2019 GIMONS
Connect type : AIBOM PRODUCTS version

+----+----+------+-------------------------------------
| ID | UN | TYPE | DEVICE STATUS
+----+----+------+-------------------------------------
|  0 |  0 | SCHD | X68000_V4.HDS
+----+----+------+-------------------------------------


sampson

It's likely the location of your HDS vs where you are running the command. Rather than do that here's my setup for rascsi:
First setup the general folder for where your images will live:
sudo mkdir /var/rascsi

Now move the binaries for your board to an area that is within your path. I used /usr/local/bin. BE SURE TO USE THE PROPER BINARIES FOR YOUR BOARD! If it's a big green thing that says gamernium obtained from booth you're in the right spot.
cd /home/pi/Documents/rascsi144p1/bin/raspberrypi/gamernium
sudo cp ./* /usr/local/bin


Now move your image to where your images are supposed to live, this is where you're having an issue - you're in /home/pi/Documents/rascsi144p1/bin/raspberrypi/gamernium and I'm going to guess that X68000_V4.HDS resides in /home/pi/
cd /home/pi
sudo mv X68000_V4.HDS /var/rascsi


Now try to mount the image
/usr/bin/sudo rascsi -ID0 /var/rascsi/X68000_V4.HDS

If this works congrats, you have your layout setup properly.
run the command "nano /etc/systemd/system/rascsi.service" and put the following contents in it:
[Unit]
Description=RaSCSI
After=syslog.target

[Service]
Type=simple
WorkingDirectory=/home/pi/
ExecStart=/usr/bin/sudo rascsi -ID0 /var/rascsi/X68000_V4.HDS -ID1 BRIDGE
TimeoutStopSec=5
StandardOutput=null

[Install]
WantedBy = multi-user.target


Press ctrl+x, hit Y, enter to save the file.
Run the command "sudo systemctl enable rascsi" and it will now auto-start on boot up. You can then use "rasctl" to interact and no longer need to use sudo. I also placed scripts in /usr/local/bin to allow easy switching between pc-98 and x68000:
pi@rascsi:~ $ cat /usr/local/bin/pc98
#!/bin/bash

for i in {0..7}
do
rasctl -i ${i} -c detach
done
rasctl -i 2 -c attach -f /var/rascsi/pc98-hd.nhd
rasctl -i 1 -c attach -t bridge
#rasctl -i 1 -c attach -f /var/rascsi/pc98-games.nhd
pi@rascsi:~ $ cat /usr/local/bin/x68k
#!/bin/bash

for i in {0..7}
do
rasctl -i ${i} -c detach
done
rasctl -i 1 -c attach -t bridge
rasctl -i 4 -c attach -f /var/rascsi/x68000_human.hds
pi@rascsi:~ $


With those I now can just type "pc98" or "x68k" to auto-switch setups.

Also to note using id0 might be "iffy" as it is usually reserved by the system. This is why I'm using 4 for mine and 1 for the bridge.

Ex68Kay

Thank you I will try that later very well.  :) 8)
Did you ever set up the RaSCSI to display the RaspberryPi directories on the X68000? Is that worth doing? It seems easier to just fill the Pi with x68k stuff and just run it from there however I am not sure it even works that way but probably can.

sampson

Yes it's worth doing and extremely simple. The commands I provided setup the scsi bridge on 1 and you just need to install the driver.

First copy rascsi145/bin/x68k/RASDRIVER.HDS on to the raspberry pi. Then use rascl to mount it:
rasctl -i 2 -c attach -f /wherever/you/put/RASDRIVER.HDS

Boot the computer and it will show up as drive B:\
Copy it to A:\SYS
Turn off the computer and detach the driver hd image:
rasctl -i 2 -c detach
Turn the computer on again and edit A:\config.sys and add the following line at the end:
DEVICE = \SYS\RASDRV.SYS
Reboot once more and it should now show up as drive D:\ and the root of the raspberry pi. Now you can just scp files to the rpi and use LHES to copy them into the computer rather than deal with any form of media.

Ex68Kay

I apologize for my ignorance but to be fair I never used a Sharp X68000 emulator let alone an actual unit before.
I did everything in the first reply you posted and it isn't booting into the image when the X68000 is plugged in. It Shows a SASI in HD0 and nothing in the rest of them then asks for a disk. I have a Master Floppy so I changed the Boot in by using the ui prodivded with switch.x, i changed it to boot hd0 and the ram option ed0100 or something. How do I get it to work?

sampson

I'm not sure, I'm using SCSI on mine instead of SASI. You might have some luck asking in the SASI thread if the image is now mounting fine and showing up if you do rasctl -L inside raspbian.

Ex68Kay

What do you mean do rasctl -L in Raspbian?

The drive needs to stay SASI due to the driver limitations -- "There is a software driver that allows SCSI to work on SASI machines, but it’s limited and a lot of stuff like virtual floppy drives for image loading will not work at all."  https://www.videogameperfection.com/2014/04/04/worlds-x68000-setup/

This page says SASI will work on RaSCSI: https://www.techrepublic.com/article/using-a-raspberry-pi-zero-scsi-adapter-to-bring-legacy-and-retro-systems-into-the-future/
I will look into rescl -L and what that should do