Question About accessing switch.x from sxwindows and cf card question

Started by cometclean, August 19, 2017, 05:59:16 AM

Previous topic - Next topic


Greetings, I need to access switch so that I may change some settings on my x68k, unfortunately my human68k OS floppy disk isn't working. My only option is to use my sxwindows disk and try to access command or switch from there. Does anyone know of a way?

I also have a cf card and a cf card reader that will run in sasi (my x68k in an expert model). In order to use the cf card will I have to partion the drive into a bunch of 40 mb sections? Can I just copy pre made HDD image to my CF card or is there a process to copying or restoring the image unto the drive? Right now I'm totally lost with this :/ 



regarding the CF question :
Yes SASI is limited to 40Mo partition
To use an HDD image you need to restore it on your CF, with WinImage for example
If you are talking about the HDD image (V4 for example) you can't use it on SASI disk because it's more than 40 Mo

If you need the human68k OS disk i can send one, just PM



So if I had to I could just create a custom image that has human68k and restore that to my drive?


SX Windows has it's own control panel like GUI for changing switch settings.  Been a long time since I've used it, but iirc you have to right click on one of the icons and select it.  Just keep trying and you'll find it.  You can also load up a command prompt window in SX and run normal switch.x through that as well.

For creating a SASI image, the best plan is to format and setup partitions on your real system first.   Then copy the files you want from the NFG image into yours.


Thanks for the tip, I was able to change my setting in SX Windows.. Now I have a new problem

I Used WinImage to copy a disk imag I found to my cf drive and voila it worked! So I went ahead and followed a great guide to make my own image, and I tested ti with XM6 emulator and copied it on my CF drive via WinImage. Unfortunately it won't boot. I even tried to put the image that did work back on the CF and it won't boot either.. Is there a special process to formatting before restoring a new image on the CF?



I figured out what the problem was! I had my cf reader set to look for 16 partitions or so even though I'm currently only running one. This was causing my program to load unbearably slowwww... I'm pretty stoked now to say the least! Thanks guys!