PLEASE need help to install scsi2sd on x68000 ace

Started by marshalld12, December 09, 2015, 10:08:58 PM

Previous topic - Next topic


hello ^^
sorry for my poor english...
i have a problem with my x68000 scsi board just arrived and i want to install my scsi2sd ^^

i have put my scsi2sd in a scsi enclosure,update with the latest firmware and set to id0,then i have follow this tutorial:

after i go to switch,to verify if the id of scsi

and i reset the x68000...i have this:

and after,the floppy boot:

i want to return to switch menu and it's crazy...the scsi id is automatically turn on "7"...

can you help me please?i have forgot one thing?
thank you very much!


I found this on the site:

"For SCSI2SD the following settings were used:
Termination On
Parity Off"


How are you writing the SD card for the unit?  I'm not sure that you can just copy files over, you need to restore an actual formatted image to them.  Otherwise you will need to use the system disk on the x68000 to format the hard drive and then install stuff conventionally from disks etc or using disk explorer on your PC.


hello and thanks for your reply ^^

now i have the masterdisk v3 and i can use "gover hd" but always the same problem...
after the sdcard format,i can't copy the files inside because the sdcard must be formated by my computer...

can you help me please?
thank you!


i have edit the first post with the pictures,i think it's better to understand my problem
i hope i will find a solution...
thank you!


Have you tried flashing one of the existing hard drive images available in the archives on this forum?


flashing hdd image?
yesterday,i have try more times with the help of eidis,thanks a lot ^^ but no success,i think i'm almost!

this is my config.sys

i set the scsi2sd on id0
i put a 2gb micro sd into my scsi2sd
i boot from masterdisk v3 and i go to scsiformat to create a partition,my scsi2sd is recognized...then i go to bootflags...
i reboot and i go to bootset...
after that,this is the x68000 boot screen

i put the 2gb micro sd on my windows10 computer to restore the hdd image with winimage and i re-put in the scsi2sd
i reboot the x68000,i have the sxsi booter but no boot and the x68000 boot on the floppy drive...

a strange thing,before to restore hdd image,on the x68000 boot screen there was "drive c: is available"...and after i have this...

my switch menu,all is ok?

i think i'm almost...but what is the problem...?


nice remark from eidis,maybe my micro sd card is bad...

tonight after work i will test with a new 16gb micro sd class10,on the website of scsi2sd,class10 is recommended...
and my 2gb card is a class4...

i put the 16gb micro sd in scsi2sd to make scsiformat and after i put the same card in my win10 computer to restore the hddimage file it's ok?

thank you very much!


don't you need SCSI drivers in SRAM to boot a scsi2sd on a SASI bus?


I believe the SD2SCSI will natively support sasi but I'm not sure.


Quote from: Opethian on January 22, 2016, 12:48:05 AM
don't you need SCSI drivers in SRAM to boot a scsi2sd on a SASI bus?

eidis tell me "no"...i will try later today with the new micro sd ^^


i have try different scsi id and the new micro sd card...and no success...
i don't know where is the problem...
the scsi cable is good because the scsi2sd is recognized by the x68000...

and it's strange....for example,when i put the scsi2sd on id3,the boot screen of the x68000 tell me "device with id0 status:does not operate"....



isee you have BOOT set to ROM in switch have you tried STD or SCSI0?


yes i tried to put STD and no success...

and if i put SCSI0 in boot and "0" for the scsi id,i can't quit the switch menu...
very strange...

eidis tell me maybe this is the power supply inside my scsi enclosure...i will try with an atx psu or another psu in a external hdd...

if somebody can explain me step by step the order of installation...i'll be very grateful ^^

i have order the necessary to made a sasi cable to put the scsi2sd internally in my ace...


This is from the scsi2sd website:

Sharp X68000
SASI models supported. See for information on building a custom cable.
needs J3 TERMPWR jumper
Set to SCSI ID 3. ID0 will not work.

This means you probably dont need SxSI in SRAM. You would set the ID of the scsi2sd to 3, the SCSI_ID line in SWITCH should be 7, and the BOOT line should be SCSI3.


i have try this now and no success...i don't know where is the problem... :-\
i have only 2mb of ram on my x68000,you think it's enough?

it's possible for someone to made a sasi cable for me please?

thank you ^^


RAM doesn't matter.

Probably someone can make you one.

Good luck.


Have you connected the SCSI2SD unit to your PC with a USB cable and used the utility to set the unit's SCSI ID to 3?


I recently configured a SCSI2SD on an Expert HD, and found that sometimes it would appear to save settings, but then they wouldn't persist. Make sure you load them back from the device after saving them to ensure that they wrote correctly. You must also modify CONFIG.SYS to select SCSI ID 3 or else you can't boot.