"Abort, Retry, Ignore, Fail" errors in DOS

Started by 98digger, February 22, 2015, 02:55:06 PM

Previous topic - Next topic


Hello NFG Games Forum,

I was recently able to figure out how to erase the emulator headers from PC-98 HDD images; FreeDOS(98) boots up on my PC-9821
Ce2 without any problems.

I first tried playing music from "Corpse Party" (RPG Maker game) using the RPG Maker MUSIC.COM. This worked fine, but when I
I tried running the actual game, errors appeared when sprites were supposed to be drawn to screen. The error said "ERROR
READING FROM DRIVE C", and caused the PC-98 to freeze (I had to reset it to return to DOS). Next I tried running the Touhou
games; they all froze after the "ZUN Soft" intro sequence and displayed "Error reading from drive C, Abort, Retry, Ignore,

I created another FreeDOS(98) hard disk image and tried to run the Touhou .exe's that are supposed to generate the game's
files. After generating two of the files, the program froze and the PC-98 required a reset. I re-ran the file and again it
generated two more of the files, but failed to make the rest. Running any games simply froze the PC-98.

I also tried running MSDP (FM music playing program); it failed to display any files and folders in its small system

I do not think that the issue is FreeDOS(98)'s fault; FreeDOS(98) never has had these issues within emulators in my

Does anyone know what the problem I am having might be? Any information on how to fix it?



I've recently been working on setting up a FreeDOS(98) image to the point where it can run Touhou without any issues. I believe that the issues I have been having with FreeDOS(98) all have to do with the FDXMS.SYS driver. Below is a quote from the Wikipedia page on FreeDOS:

QuoteThe disk cache stores recently accessed disk data in XMS for faster access and less direct disk access.

This means that, by default, FreeDOS is putting portions of the HDD into RAM for quicker access. By doing this, I believe it is breaking compatibility with PC-98 DOS programs. Below is an issue I am having with the original Corpse Party game that I believe is being caused by the XMS driver:

Also, I tried changing the RAM settings in the BIOS and, upon reboot, FreeDOS appeared to start fine. But when it tried to load the XMS driver, the screen was filled with random flashing and patterns. The PC-98 then locked up and would not boot properly until I changed the RAM settings back to the "1 MB" option.

So, I'll try removing the FDXMS driver from the image and rewire CONFIG.SYS to use EMM386 instead; this should eliminate the "Abort, Retry, Fail" and "ERROR DRIVE C" issues. In the meantime, I am trying to track down MS-DOS 6.2 or MS-DOS 5.0 on Yahoo Auctions in case I am unable to get FreeDOS(98) working.