October 21, 2019, 07:37:56 am

News:

Upload your images to this forum!.  The internet can't be trusted.  NFG can.  (probably)


YAHDI (yet another hard disk image)

Started by kobushi, August 10, 2014, 12:37:17 am

Previous topic - Next topic

Nana

March 09, 2015, 03:41:03 am #40 Last Edit: March 09, 2015, 04:10:46 am by Nana
Thanks for your help. Unfortunately, that doesn't seem to have changed much. Attempting shift + boot still doesn't bring me into dos.

SW 2-8 was set to ON before, but that's the 5mhz mode for GDC clock, which I believe this image required? I tried switching it, but that unfortunately had the same results.

So I tried switching my CF drive/adaptor to the other IDE port, but just got the lovely 'システムディスクをセットして下さい' error (AKA the same you would get if booting with no drives whatsoever).

Hmm. On said CF adaptor, the lights for power and master (just indicating that it detects my CF card) are lit up, but not the LED for activity. All the jumpers are at defaults, which makes sense. (connecting through the floppy power, so +5v, set up as master, and 'from external' power.) Here's the manual for the adapter I'm using, just for the hell of it.

http://www.sybausa.com/resource/SD-CF-IDE-A/SD-CF-IDE-A_Manual.pdf

I'm feeling my next step may just be to buy another floppy drive in hopes I can boot through that and see if I can just install over the hdd that came with this thing.

EDIT: But on the other hand, the GRPH+2 during boot trick worked, and now my monitor doesn't flash around saying 'input not supported.' That's a victory in itself!

EDIT2: And yeah, my image files are all correct. I was burning from the .img directly to begin with, but I checked just to make sure, and first bytes of my modified image were still the correct EB 0A 90 90. I switched out this image with the very original 542mb image on my CF just to make sure, but got the same result.

kobushi

The GDC clock is unrelated to your boot issue, but you always want to set the GDC clock to 2.5MHz for DOS gaming.

Have you tried setting the CF adapter to slave mode?

AnnaWu

Hello kobushi,

euee released new updates. :)

NHC Ver.0 alpha44b 2015/03/08
NHC is a tool which can convert different (virtual) hard disk image formats (PC, PC-98xx, FM-TOWNS)

http://euee.web.fc2.com/tool/nhc.html#nhc

NDZ Ver.0 alpha07 2015/03/08
NDZ is now able to detect/load FM-TOWNS (*.h0-*.h4) and PC-98xx (*.hdi/*.thd/*.nhd/*.hdd) hard disk images

http://euee.web.fc2.com/tool/ndz/ndz.html

Nana

Hmm. Yet again, that doesn't seem to have changed much.

Interestingly enough, as an experiment, I loaded up the machine with the adapter plugged in but not the CF card, and I actually got the exact same issue during boot.


I'm completely at a loss here.

kobushi

@AnnaWu
Thanks! FM Towns hdd support should be very useful.

@Nana
I don't know what else to say. I've used two different SD-IDE adapters and a CF-IDE adapter with various PC-9821 desktops and notebooks without problems. My SD-IDE adapters don't have any jumpers or master/slave options.
Make sure that the IDE pins are aligned correctly. If you have an IDE CD-ROM drive, try disconnecting it temporarily while you troubleshoot the HDD.

98digger

Quote from: Nana on March 10, 2015, 02:25:06 pm
Hmm. Yet again, that doesn't seem to have changed much.

Interestingly enough, as an experiment, I loaded up the machine with the adapter plugged in but not the CF card, and I actually got the exact same issue during boot.


I'm completely at a loss here.


I'd say your CF card or the CF-IDE adaptor is probably dead, or the CF card you are trying to boot from may not support being used as a hard drive. Also, I probably should point out that when you connect the adaptor to the PC-98, you should use the IDE cable that was included with the computer. I myself tried to swap the original cable with a longer one and experienced similar problems to the ones you are now having.

What type of CF-IDE adaptor and CF card are you using?

SkyeWelse

March 21, 2015, 03:44:16 am #46 Last Edit: March 21, 2015, 03:46:13 am by SkyeWelse
Hi Nana,

I've got two different versions of CF adapters hooked to my PC-98Ce2. One is connected to the front IDE bus and the second is connected to the IDE bus meant for the CD-Rom currently. I have heard that some PC-98 machines may have their voltage wired differently so that the 12v and 5v might not be the same as what you might see in a modern day PC. Fortunately in my case, for the Ce2, my voltage for the IDE mini-molex power cable is not reversed. Though, I did test eveything using a multi-meter when the system was turned on just to be sure I knew which was which. In most cases I've heard, though another way of testing this is to see if your CF card still works after having hooked it up via the adapter to your PC-98 machine. If the CF card hasn't been completely fried, then you should still be able to talk to it using a CF reader to USB adapter in your PC. Kobushi's YAHDI image will let you view the contents of the CF Card's image, so if you are not seeing anything when hooking it back up to your PC, there's a good change that voltage being reversed could be the problem.

Ruling out voltage, what Kobushi said about checking your Jumper switches on the CF Adapter and that the IDE pins are correctly aligned with the IDE cable, that would be the next troubleshooting steps.

I don't have as fancy a CF card adapter as the one you show in your manual since it appears that you actually have two slots available for CF cards to be used. That in itself could be problematic if you didn't have the Jumpers configured correctly.

From my CF Card reader which doesn't have as many jumpers as yours does, I have mine set to Master/Slave, where the other option I could choose (but it probably wouldn't work) can be set to Slave/Master. I'm not 100% sure, but I think my internal CF Card Adapter is also set to Master/Slave as well. I have that tied to Kobushi's Dos 3.3. image for playing older games. When I boot up the Ce2, it immediately asks me which partition I would like to boot from.  From your manual of your CF Card reader, it looks like you'd want to have JP1 set to (1-2), JP2 set to (1-2) and JP3 set to (1-2).

Next thing to test is your IDE connection. Yes, the IDE cable should have a groove on it that "should" match up with the groove in the casing of the IDE pin connector on the CF Card Adapter. "Should"... But in my case, one of my CF Card readers has this fit into the groove like it should and it works fine. The other CF card reader doesn't and requires that the IDE cable be inserted in reverse. As there is no groove for it to fit in, I have to "make it fit" and really jam in in there. So that could be the problem if you've ruled out voltage and your CF still works, and your jumpers are set correctly. Give that a shot and see if you are able to get the CF card to load.

I'd also recommend doing a clean boot like Kobushi recommended! : )

Sorry I haven't been around as much everyone. I tend to jump from project to project, and currently I'm working on an MSX game, and opening a new Romhacking/Translation forum where we plan to look at some Falcom games left untranslated and perhaps some PC-98 stuff as well like Brandish 2 Renewal and AIZA: New Generation. We recently more or less finished a translation for the PSP game called Nayuta no Kiseki.

Anyhow best of luck Nana and nice to meet you as well. I think I posted on the Tokugawa forums awhile back about your Floppy Drive btw.

-Thomas

kobushi

Quote from: SkyeWelse on March 21, 2015, 03:44:16 am
We recently more or less finished a translation for the PSP game called Nayuta no Kiseki.

Nice!

Pasokon Deacon

I recently got YAHDI working and want to convert BMP/PNG screenshots to .mag, but so far I'm getting errors using ddgazou. Are there essential parameters needed for the .mag file/view driver to recognize and display images?

Also, I'm not able to use Grph+VF1 because I don't know how to rebind either of the keys on my Apple Mac keyboard (running Windows 7 via Boot Camp) in Neko Project II. Are there any workarounds for this? YAHDI's very convenient even after I've been using my own HDIs for a while, so getting the most usability from this would be great.

SkyeWelse

I've not had much luck with ddgazou either, but mainly because I wasn't able to get it to display anything but random garbage characters instead of Japanese, so I was just clicking blindly. There may be an easier windows program but I've found that this simple program called BMP2MAG run from command line on a PC-98 or inside an emulator seems to work just fine. Just make sure that your image size is 640x400 or if you want it to be a larger-scrolling image, make it something like 640x800 and it will load from top to bottom. I was able to edit an existing converted MAG file inside of photoshop and have it saved back out as a 8-bit bitmap and it seemed to work fine with the exception of there being a small hiccup when viewing the taller image with scrolling. It's probably a Photoshop program as that program is notorious for adding extra junk in the file. It's especially bad with transparencies. I hate using it, mainly because it's extremely counter-intuitive to what I'm already used to with PS, but GIMP does work a lot better for editing 8-bit BMPs and not messing with the color data too much.

As for the GRAPH+VF1 keys, not sure on that one. There is a Soft Keyboard that you can use and select various options from when LEFT SHIFT is pressed, and usually entry isn't shown on the fly but will appear when you click back to the viewer pane, however I have no idea how to hold down a combination of keys using that soft keyboard. I think I read somewhere that using NUM KEY if it exists on your keyboard in conjunction with other function keys, perhaps you can get it to work. NUM KEY is supposed to allow access to VF1-VF5 if you didn't have those keys available.

-Thomas



Pasokon Deacon

BMP2MAG works great! Sadly neither ddgazou or G・こんばーちゃ♪ 2.04 from Vector do 4-bit conversion to BMP or good MAG conversion (the latter processes them at the file level, but mag.exe will display them with incorrect color depth and resolution). This command-line app only wants 4-bit color bitmaps (and x dimensions in multiples of 4), so I've gotten a plug-in for paint.NET that will let me save edited images at this color depth; I can easily automate screenshot conversions via BPP decrease in IrfanView.

I mentioned not being able to use Grph hotkeys mainly from my suspicion that MAG conversion of screenshots taken with IrfanView wasn't going to work, but the above tool makes things simple. Thank you!

ashrion

image work fantastic in my new ce and model s2 two new pc9821 arrival, ide-compac flash
thanks
one link translate options bios? please, and explication all options? thanks

SkyeWelse

December 05, 2015, 06:18:31 pm #52 Last Edit: December 09, 2015, 03:56:23 am by SkyeWelse
Good to see another PC-98 hardware owner join the scene. I own a Ce2, so the Bios between mine and yours should be quite similar.

Not sure if a translation has been made already of the BIOS options, but if there hasn't been one I can create one with screenshots sometime. My Japanese isn't great, but it should be enough to give you a good understanding of the available options at least. Depending on the machine however, the BIOS options may be different.

These are what mine look like by the way if you wanted to compare with your Ce Bios options.

Main Menu Options:
http://retro-type.com/PC98/System-Menu/pc-9821-ce2-system-menu-main.jpg
http://retro-type.com/PC98/System-Menu/pc-9821-ce2-system-menu-main-02.jpg
http://retro-type.com/PC98/System-Menu/pc-9821-ce2-system-menu-main-03.jpg
http://retro-type.com/PC98/System-Menu/pc-9821-ce2-system-menu-main-04.jpg
http://retro-type.com/PC98/System-Menu/pc-9821-ce2-system-menu-main-05.jpg
http://retro-type.com/PC98/System-Menu/pc-9821-ce2-system-menu-main-06.jpg

Sub Menu Options:
http://retro-type.com/PC98/System-Menu/pc-9821-ce2-system-menu-01.jpg
http://retro-type.com/PC98/System-Menu/pc-9821-ce2-system-menu-sub-02.jpg
http://retro-type.com/PC98/System-Menu/pc-9821-ce2-system-menu-sub-03.jpg
http://retro-type.com/PC98/System-Menu/pc-9821-ce2-system-menu-sub-04.jpg
http://retro-type.com/PC98/System-Menu/pc-9821-ce2-system-menu-sub-05.jpg
http://retro-type.com/PC98/System-Menu/pc-9821-ce2-system-menu-sub-06.jpg

Edit:
I've started the process of translating this. It may take a little bit due to other projects I currently have on my plate, but expect to see something like this:


-Thomas


Koishi

I can't get it to work, can't convert it. Can someone just send me over an HDI file that works? Delete all the games that aren't Touhou, not interested in anything that isn't touhou.
Wondrous Eastern Legend
Record of the Sealing of an Oriental Demon
Oriental Dream Dimensions
Eastern Fantasy Township
Eastern Bizarre Tale

Koishi

Sorry to double post, but I tried to get it working on my Windows XP. I can't get it to run, when I mounted it on F: it's only a removable disk, and nothing comes up. I tried it with some other mounters, and Gizmo just re-formatted it, which erased everything on it. How do I get it working on XP? I want to play Touhou! >:(
Wondrous Eastern Legend
Record of the Sealing of an Oriental Demon
Oriental Dream Dimensions
Eastern Fantasy Township
Eastern Bizarre Tale

kamiboy

Seems I cannot get HSB to work for the life of me. It appears to hang when it should be rebooting with the config from a directory. No error messages or anything either, so I am at a loss as to what to do.

Any advice?

kobushi

Let's say you have a game installed to A:\kamiboy, and the directory contains a custom config.sys and autoexec.bat file you want to use.
In this case, type HSB A:KAMIBOY\
The important thing is don't put a backslash after A:, but do put a backslash at the end.

kamiboy

I know hot to use the tool properly. Trouble is it just don't work. Seems to be incompatibility issues with my machine.

kobushi

In that case, you might try modifying the HSB device settings in your main config.sys. The HSB line goes at the very top, before everything else.

RetroPCfan

November 22, 2016, 10:58:36 am #60 Last Edit: November 22, 2016, 11:01:33 am by RetroPCfan
Hi guys! Don't know why but default Yahdi HDD image never worked for me on PC-9801 , i guess that's because of scsi hdd interface and maybe a special formatting algorithm or something, 9801 scsi hdd images aren't windows-readable at all. I tried it on several 9801 models and got black screens and nothing else. Anyway i figured out how to boot Yahdi on PC-9801FA . Just have to format hdd/cf-card on your 9801 under dos (i prefer dos 6.2) and after that copy all Yahdi files on freshly formatted hdd and that's all! This should work on any 9801 which meet the minimum hardware requirements. Hope this will help to any other 9801 hardware owner out there! 

But anyway i have a problem - when i listen to music and open msdp or fmdsp player then sound becomes stuttering and completely unlistenable especially on tracks which using ppz8, without players everything is fine and is on fullspeed. Also all music sounds just fine on my 9821na12 laptop with fmdsp or whatever (not surprised there are mighty pentium 120mhz inside!))) !  Is my 9801 cpu too weak for all those cute visual players? My pc config is : PC-9801FA with Buffalo HFA-16Q 486dx2 64mhz cpu upgrade, BA34 8mb memory board , 9801-86 sound board in C-Bus slot1 , scsi ,roland midi and Ga-drv/4 gfx card. Thanks in advance for any help ! )

SkyeWelse

Did you ever replace the capacitors in your PC-9801FA? Just before recapping my PC-9821Ce2, everything had been working fine with running games and playing music via MSDP, but then I stared noticing that the music would just stop playing right and make a terrible sound. Shortly after, the CF card would have a difficult time loading DOS, if it loaded it all. I replaced all the caps and it fixed the problem. Also, are you able to get any OPNA sound out of your games using your PC-9801-86 CBUS? I think the Farland Story games are a good test since you can switch between FM, 86 and MIDI in the soundtest. I'm wondering if perhaps there's some kind of BIOS dip switch setting that you need to do to enable the PC-9801-86 correctly.

-Thomas

RetroPCfan

Yes all caps on FA mobo and anywhere else were replaced as my 9801FA was a real junk :) Anyway i dont think it's a capacitor problem , i never had any sound issues while playing farland story's , groundseed and lots of other games so far.  By further investigation i've noticed that all fmp/pmd/mdx music sound just fine and smooth if load drivers and MSDP player from BM "audio" section. FMDSP stays laggy and stutter even in BM ... About bios settings i guess i've already tried almost if not all dip switch combinations but without any positive effect. Maybe i need a faster cpu? There are better 9801FA accelerators out there with cpu's somewhat equal to Pentium 75+. Anyway i feel happy with msdp , everything works just fine in BM but of course it would be perfect if fmdsp would work just as fine!

Laevateinn

Does anyone know if there's something special you need to do to install an image using Mac/Linux?

I have a PC98 Ce2 and am trying to use a CF Disk on it. I tried copying the image to the disk using
dd if=./PC98-542MB.img of=/dev/disk3 bs=1m

But when I install the disk, after it checks the memory I just see a black screen for a few minutes until it asks me to set a system disk.

I have a bunch of floppy games but they all give me a system disk error as well.

famiac

Copying the file over is not the same as writing an image to disk. Use a program like winimage to do that for you.

papa_november

How would I go about making the image bigger, e.g. for machines that can handle 2GB drives? Could I just go into FORMAT and add another partition?

dos

June 03, 2019, 06:45:51 pm #66 Last Edit: June 03, 2019, 06:50:52 pm by dos
Thought I'd share my customized YAHDI image, when I got my PC98 I was looking for something similar to the X68000 HDD images which have a huge variety of games to explore, but could not find much. I went through the library and added most of what's playable for non-japanese speakers and is at least halfway decent or at least interesting. There aren't any western games on this because I personally would rather play the originals on PC/AT setups or Amiga or whatever and feel like they just waste space here. Included are the recent Dead of the Brain and Cybernetic High School translations. A few other translations are included, including Touhou.

This image boots straight to FILMTN, everything is in the games directory. Everything has a !start.bat. Everything has been tested and confirmed working on a PC9821AS and in neko21fmgen. A small minority of games (like Thexder) require that you have a 24khz monitor and set your CPU speed to LOW. Fair warning, there is a shitload of pornographic or otherwise objectionable content here, it's inescapable on this system. 

Headerless .img for writing to a CF/SD card, use

nhdgen.exe /auto /merge

To generate a nhd for emulators.

https://mega.nz/#!98AW3YSQ!ESYg_t_F4hNarg89zQZD3lG62G6jwB9CiDgd-d0rhGg

A big thanks to Kobushi for providing the original image to make this possible, and to various people on the PC98 discord who helped when I had questions.


LowDefAl

Thanks for your efforts dos. My keyboard, mouse and SxSI riser for my DA has just passed customs so this is nicely timed. Now I don't need to write any disks in advance and can get right onto DOTB.  8)

dos

Quote from: LowDefAl on June 07, 2019, 05:40:51 am
Thanks for your efforts dos. My keyboard, mouse and SxSI riser for my DA has just passed customs so this is nicely timed. Now I don't need to write any disks in advance and can get right onto DOTB.  8)


No problem, I'll be uploading an updated version with more stuff near the end of this weekend so stay tuned

dasfool

Quote from: dos on June 08, 2019, 08:16:18 am
No problem, I'll be uploading an updated version with more stuff near the end of this weekend so stay tuned

Looking forward to it, dos!

dos

sorry guys I have been working on it but my CF card has some problems once it get filled up a certain amount (but not full), so I can't test on real hardware, and I don't want to put out anything that I haven't confirmed to be 100% working on hardware. I have a new CF card coming, and once I confirm everything works I'll put out V2.