ExpertHD power-off [FIXED]

Started by caius, November 13, 2012, 02:41:31 AM

Previous topic - Next topic


I got and ExpertHD (CZ-612C) with a bad PSU, it worked a couple of time and then stop.
So ,I repaired the PSU changing almost all the components (not only capacitors).All is working now, the only problem is that when I turn the PSU switch ON,  the  fan starts to spin, the front X68k LED is green and when I turn the X68K switch I can enter in the system.If I turn the X68k switch OFF,  the system goes down fading but the fan keeps to spin with green LED so all I can do is turning the PSU switch OFF.In conclusion, there is no more stand-by (red LED).The same happens with a regular ATX PSU so it's not matter of PSU.It doesn't depend from X68k capacitors since I replaced  them all (except in the FDDs).
I know that the power-off sequence is also software controlled, I dump the ROMs and they matches the good ones.I post them here if someone is interested:

Any ideas about?

I tried also the original PSU standalone and it starts when I turn the switch ON.
Isn't it strange without any load and disconnected from the unit?


Hi Caius !

Your problem is almost sure located on the IO board. I've faced this one on my SUPER.
Here is the power on/off logic behind the /PSON signal (named CH2 in PSU shematic) that I have drawn some time ago :

As you can see, a condition using 4 signals is used to get the X68K turn on/off correctly :
- Via the front power switch (/PSON)
- Via the RTC (Real Time Clock) alarm signal (/RTC_ALARM)
- From the expansion bus (signal /EXPWON)
- A signal from the system controller (the soft sequence you're talking about, signal /MPWOFF).

On normal operation, all these 4 signals must go logic high (+5v) to get a system shutdown.
The problem you have might be due to a signal always stucked Low.

What I've done on my SUPER is just checking for the MFP GPIO port.
If you look to the buffered IO part in my schematics, 3 of these signals are connected to the MFP GPIP port. They are connected like this :
- /PSON ==> GPIP2

Here is a small C code that will check these signal (toolchain promoval ! :D )

#include <stdio.h>
#include <stdint.h>
#include <dos.h>

int main (int argc, char **argv)
  /* MFP access restricted to supervisor mode only */
  int sr = _dos_super (0);

  /* MFP address = 0xe88000, a 8 bits device */
  volatile uint8_t *mfp = (volatile uint8_t *) 0xe88000;

  /* MFP's GPIP register is the first one.
     Power signal are available through these bits :
       Bit 0 : RTC alarm signal
       Bit 1 : External port power on/off signal
       Bit 2 : Front power switch */
  uint8_t gpip = mfp[1] & 0x07;

  printf ("RTC_ALARM = %d\r\n", (gpip & 0x01));
  printf ("EXPWON = %d\r\n", (gpip & 0x02) >> 1);
  printf ("PSON = %d\r\n", (gpip % 0x04) >> 2);

  /* Return to user mode */
  _dos_super (sr);

  return 0;

Ready to use executable :

Execute it more than one time. What you should get :
- RTC_ALARM = 1 or 0, depending on the current RTC configuration.
- EXPWON = 1
- PSON = 0

if RTC_ALARM always stay to 0 :
- Bad RTC chip (reference = RP5C15)

If EXPWON = 0 :
- Check the expansion riser, or remove it.
- Check the "Remote" plug on the back, if I remember right, it's also connected to this line.

if PSON = 1 :
- Damaged resistor R54 (should act as pullup)
- Bad power switch

And if all is ok, it could be :
- Bad IC28 (stucked output).
- Bad Q9 transistor (shorted).
- Bad C64 (generating noise).
- IC29 might have bad output on pin 5.
- The power signal from the main board, which I miss infos actually. A fix to this could be soldering a 10K ohm resistor between IC28 pin 10 and 14.

Humm... I think that's all I have to say ! :D


Hi Lydux, I'm very glad to hear you again!
Some minutes ago, before reading you reply,  I noticed the Power Test program on FTP and I immediately thought;"There is the Master behind this".And , of course, I was right...
However, it's avey annoyng issue since my ExpertHD works perfectly except for this.
Anyway this problem was certaily caused by a stupid overclock mod  I found inside.This mod consisted in a cutted trace, a cutted ferrite bead and two oscillators connected to some IC (now I didn't remeber which ones) ,  one @ 5MhZ and other @70Mhz!
Due this overclock mod I already changed a burnt MC1488 near the RS232 connector , this damaged IC prevented me from power on the unit, it was always in stand-by with the TIMER LED flickering
And now this other problem.

Some minutes ago I noticed a very strange thing...I forgot to connect the the two pins power connector - labeled  (B-MAIN) on Expert PSU schematics- which carries +5 V to the motherboard and the system worked the same!Then, I measured the two pin heders on the motherboard and +4.91 V was already present...bah, I don't know..maybe it takes it from that 34 PINs (not the FDD one) connector..

Anyway I'll try your utility and let you know,But I suspect a bad RP5C15 RTC IC because  I remember that +5 volt was not present on PIN 18
Anyway, stay tuned for further news!Thanks again, Master!

I just read your PM, I missed you , too! :-*
Joking apart, later I'll reply you in private telling you what I have done in this months of silence... :D


This is the result of testing with Power Test program :

on 20 launching times :

- EXPWON = always 1
- PSON = always 0

RTC_ALARM = 10 times 0 and 10 times 1

So, conclusion: RP5C15 is the prime suspect (and the burnt MC1488 I changed is just near the RTC IC)
Now, I will disassemble the unit and test also the other possible involved ICs
Stay tuned!

I think we must finish the floppy project, another small effort and it will be ready, the conclusion was very near, it would be a pity..NEVER GIVE UP!


Quote from: caius on November 13, 2012, 07:42:10 AM
RTC_ALARM = 10 times 0 and 10 times 1

You misunderstand me, that is the expected result !

You should look around the last possibility I wrote.


Yes, pardon Master, I misunderstood.
Anyway  I adapted your schematics on Expert motherboard, IC names are slightly different, you have to add the digit 2.For example IC28 in ACE is IC228 in Expert, Q9 is Q229, C64 is C264, R59 is R259 an so on..
Tomorrow for first I will test  TTL searching for stuck output, then other components..I feel that victory is near, thanks to you my dear Lydux.

Could you confirm that power supply pin of the RC5C15 is not directly tied to +5vsb?


Confirmed !

The RTC is powered by the battery (to keep the clock alive while system off) via the supply voltage supervisor (TL7705).


Some updates:
I checked with a logic probe the outputs of the 'IC28' (74LS08) and pin 6-8-11 are all stucked in low state.Then, I fired up the logic comparator and when I put the clip on the IC the PSU powers off.So, I presume, IC 28 is bad.Now I will desolder it and test on my programmer.Stay tuned!

Other components involved in power circuit are good (Q9 is good, pin 5 of 74LS244 is in high state, etc..).The only doubt is on capacitor 'C64' but  I don't think is bad since I replaced it some days ago.


I got it!This was the culprit:

It was really bad.
Lydux, I love you!If you was a woman,  I would marry you! ;D

Now the ExpertHD is perfect, the only issue is a hissing noise that sometimes come out from PSU, I presume.I don't think it come from some capacitors since they are new, maybe it depends from the transformes or chokes.By the way, I noticed that 78M12 regulator is not heatsinked..very strange.
Lydux, thanks again..pratically you repaired it, I put only my hand, you are the mind as always.

If someone is interested in repairing Expert PSU, I can provide the part list  I used instead of original ones (very hard to find nowadays)
Anyway, this thread deserves a Wiki article.Isn't it, Eidis?


Fantastic work Lydux and Caius !

Another mystery solved. Lydux, your knowledge scares me, in a good way ;) Caius, please post the list of alternative replacement parts, their numbers on X68000 motherboard and some pictures of the previously damaged motherboard area. This will be a very good Wiki article.

Keep the scene alive !

Update: The article is up. Lydux and Caius, please check if everything is right and let me know your thoughts and suggestions.

Soft-Power troubleshooting and repair

P.S. Caius, any chance of getting the alternative parts list for X68000 PSU? ;)
X68000 personal computer is called, "X68K" or "no good good" is called, is the PC that are loved by many people today.