Confirmation of X68000 boot process

Started by lupin3rd, June 10, 2023, 08:38:19 AM

Previous topic - Next topic


I have 2 systems (Compact XVI and ACE HD), trying to get one that will boot into the OS and do more than tell me to insert a floppy. I have posted some of this to the r/68000 subreddit, and I recognize a few names here from that place.

Both machines power up and display the insert disk image.

The XVI is the one I think I'm most equipped to get booting. I have a SCSI cable that connects my ZuluSCSI RP2040 compact to the machine. At boot time, the ZuluSCSI flashes green once. The debug logs indicate that things are working, the image is found, none of the commands are throwing errors, etc.  I'm attempting to boot the V4 image.

I've cleared the SRAM and tried rebooting holding various keys down -- CLR lets me clear the SRAM, none of the other key suggestions I've read about do anything, other than OPT.2, which I think is telling me that I don't have the terminal hardware connected. (Anybody interested in one of those devices? I have two.)

My questions are these:

  • Should the XVI be capable of booting the HDD without ever getting the floppy drives to boot? (Assume the SRAM is cleared, because it is)
  • Is there a ROM I can burn or use to statically set a bootable SCSI ID? (In lieu of having a driver or config setting stored in SRAM, since I don't have working floppy drives)
  • I've seen others mention getting ZuluSCSI to work, are they using .xdf files, or using a tool to convert them to .hda or .hds?
  • I've compiled the fathuman program from github to check the contents of a few .xdf files that I have. For .xdf files, it can list the file contents, should I be able to see the contents of the .hda or .hds files too?  Currently, the V4 files don't list any of the files within using this utility.
  • Since the ZuluSCSI seems to be aimed at being used as a SCSI HDD replacement, can it not also be seen by the system as a FDD? I know it supports it by naming the files FD(S:L)_(SectorSize).(img|iso|hda) -- but does the fact that it's connected to the SCSI HDD connector on the back of the machine with an MC-50 connector prevent it from booting as a floppy drive? Or does the x68k only support booting from non-SCSI floppy drives?
  • I bought a few of these PCBs, and have the components to assemble them. Has anyone else used one, or does anyone else have one? Would anyone be interested in getting one of these kits in exchange for some other hardware to help get me up and running? I believe I have enough parts and PCBs to build out 4 of these now since I already have one 98% assembled. I dropped it and the SD connector broke off and pulled some traces with it. I was so pissed, I just walked away from it, that was 4-5 weeks ago.

It's awesome this community exists, I've learned a lot and managed to get these two machines getting to the insert disk screen. Originally, neither one would do so, so I'll call both of them mini-victories.


Okay, miraculously I seem to have gotten my Compact XVI booting with the 3.5" drive. I think I had some issues while getting an image written to a floppy under Ubuntu.

Long story short, the USB floppy drive wasn't being detected properly under Ubuntu, which was causing issues trying to get the Mode3 floppy drive to format a 1.44MB floppy as a 1.2MB disk. After I got my udev rules setup to fix that problem, and tried about 2-3 floppies, I managed to get a disk formatted and a working image of Human68k 3.02 onto it.

I launched switch.x and configured the system to boot to HD0 and saved out. I relaunched switch.x immediately afterwards to verify it had saved my preference to boot to HD0, and it did.  When I tried to boot without the floppy disk, however, it did not load from the ZuluSCSI. Can anyone shed light on what the default SRAM option should be set to? If I want it to remember to boot to HD0 in the SRAM config, what does the switch.x option for SRAM need to be set to?

I booted up the floppy again and noticed that no SCSI drivers seem to be loading during the boot process. I ran diskid.x and verified that I could see the 3 HDDs showing up as IDs 0-2. They still aren't booting however. I saw something about using the Help key on startup to set the start disk. I got into the menu of 9 options, and even though I was using Google translate to help look for the option, I couldn't find anything about selecting the boot device.

Can anyone help with that?


Okay, I finally have the system booting with the ZuluSCSI as the startup disc on the Compact. I need to do a write-up, because most of the instructions that are lying about don't apply or work exactly the same on the Compact systems.

Next step, locating midi drivers and getting them added to the config.sys file.

Andrew PI

Hi Lupin,

I see on one of your old posts you said you had many spare board?

I'm looking to get hold of a XVI (non-compact) I/O board and maybe a main cpu board to help me find the black screen on boot issue I have with my XVI (non compact version).

Can you help please?

Where are you located I'm in the UK.