The HD saga - almost there

Started by pmack, January 28, 2012, 12:00:18 PM

Previous topic - Next topic


Hello all

So I finally got my CardDock SD drive to work! It's been a few months since the start of this ( so I really appreciate your help.

I do have one question though. I am using the X68000v2 image from Eidis and all games from the Games directory work great. The ones from Games2 and Games3 though don't. I read the instructions here ( but the actual behavior is not matching. Here is what happens (using DaiMakaiMura as example):
- I launch the !start.bat from the DI and then get the LHES: error message. I can either click Enter or Esc and I go back to DI
- Once in DI however, if I try to launch the game again I get the same LHES error

That happens to pretty much all Games2/3 games. If I click ESC multiple times in DI I get to a screen that shows me some options (Y, Q, B, P, E, A with Japanese descriptions).  If I click Q for instance, I got to another UI and if I click ESC again I go to DOS. Even there, if I navigate to the game's directory and run !Start games don't work. For DaiMakaiMura for instance, I get a message right after DM.X (all Japanese) and nothing happens.

Funny thing is that as I was trying some total random key punching while in this second UI, I got to a place where I could type but the UI was still showing. That time I got Final Fight to work. Pure luck because I cannot repro this anymore...  :) But at least I know it is not some limitation on my machine (XVI Compact, 2Mb)

What am I doing wrong?



Update: I think I messed up some of the names below (mix up the LHES UI and DI). Anyway, I found a way to run some games in Games2 (maybe all?) which is not even try to launch them from LHE. So I boot, click ESC right away and then ESC again. That way I go to a cmdline and can launch Final Fight for instance.

However, games on Games3 are not working. I launch DaiMakaiMura via !Start and it fails right after DM.X is called. I even tried to execute command.x and try to launch it from there but it shows the same error.

Eidis? :-)


  Hi Pmack !

Glad to hear that you succeeded with your mod. Don't worry, everything will be fine ;)

Games - 1MB required
Games2 - 2MB required
Games3 - 3MB or more required

Quote- I launch the !start.bat from the DI and then get the LHES: error message. I can either click Enter or Esc and I go back to DI

The main idea behind DI is that it uses less memory than LHES. If you launched DI with LHES then you are using too much precious memory because LHES and DI reside there at the same time so you can probably guess what the error message means ;) The correct procedure for launching DI is first booting to LHES, then pressing ESC and then ENTER. DI should load automatically.

But it does not guarantee that you will be able to run every game in Games2 on a 2MB machine. Many of them are memory hungry and even with DI will give you out of memory error. In such cases after exiting to DI from LHES, navigate with enter and arrow keys to directory of the desired game, press ESC and you will be in command prompt. Now type "!start" and hit ENTER.

P.S. You will have to buy a RAM expansion to run games from Games3. Keep a close eye in Yahoo auctions for one. I can tell from my personal experience that usually at least two 4MB ram expansion boards pop up during a week and the price usually starts at 5000 Yen (~65 USD). Prepare to face some nasty competition because they are in high demand.

Best of luck !
X68000 personal computer is called, "X68K" or "no good good" is called, is the PC that are loved by many people today.