January 23, 2021, 08:25:21 AM

SNES Final Fantasy 3 problem

Started by suneloon, October 19, 2010, 03:35:08 AM

Previous topic - Next topic

suneloon

Hi

New guy here.

I have a problem with my Final Fantasy 3 game.

The game is NTSC, and I play it on a PAL SNES, via adaptor.

The problem is that the in-game (inventory) menues are sometimes black. The border, and some of the headline text is visable, but the background, and contents is just black screen. This problem only occurs sometimes.

Is this a problem with the (brand new) adaptor ? The cartridge? Is it simply not allowed to access your inventory screen during some parts of the game?

I hope someone has an idea of what to try.

Thanks.

- Sune

budo-ka

This is not realy a hardware trouble but only the region software protection. The cartridge detected the PAL hardware and blocked some part of the game, the most annoying is that the ending will be lock !

I also had this problem in the past and like you thought that I was not allowed to to access the inventory.


suneloon

Ok thanks.

Sux bigtime! But its better to know i guess..

Hojo_Norem

If you can do it yourself or can find somebody to do it for you then this would be the perfect excuse to get the 50/60Hz mod done to your snes.  That should get past almost any software based region protection.
Formerly 'butter_pat_head'

Shadow_Zero

Quote from: budo-ka on October 21, 2010, 04:58:50 AMThis is not realy a hardware trouble but only the region software protection. The cartridge detected the PAL hardware and blocked some part of the game, the most annoying is that the ending will be lock !

I also had this problem in the past and like you thought that I was not allowed to to access the inventory.


That ending lock brings back painful memories ;_;
I was 'lucky' though it was the only issue when I played (using an Universal Adapter AD-29 upgrade version).