Forum Updated! 

Main Menu

Floppy drive problem

Started by Magic Knight, January 30, 2008, 07:28:38 PM

Previous topic - Next topic

Magic Knight

Hi all,

I've inserted two disks into my X68000 earlier today, the machine didn't read them properly (LED didn't light up) and now I can't get them out. Resetting the machine, powering down etc. hasn't had any effect (in the past a power down was enough).

Anyone have any ideas as to how to force the disks to eject?

Many thanks,
Magic Knight


Have you tried holding down the eject buttons while turning it on?

Failing that, you could try opening it and disconnecting the data cables to the drives.  The eject button is connected directly to the drive, and this should immediately activate the eject mechanism.

The first-gen X68000 had a dedicated FORCE EJECT button around the back, but it's the only one.  Generally if the disks cannot be read they'll eject themselves.

Magic Knight


thanks for that, I'm having trouble opening the machine though. Is it simply a case of removing the three screws at the back and then pulling the cover off, it doesn't seem to want to move, and it feels like it'll break if I try too hard. Is there something I'm missing?

Many thanks!
Magic Knight


There are three tabs to the cover, what I did to remove the cover is move the front cover a little and carefully move the  side cover back.

Magic Knight

Yes, it worked!

I managed to get it open, pulled out several cables and then turned it on and managed to get the disks out. They're ejecting disks repeatedly now, but will eventually accept them, so I should clean them well now I guess.

Many thanks to everyone!
Magic Knight