Sega Genesis Model 2 Already retouched sodder, controller still stuck in down

Started by bagelpirate, May 10, 2016, 07:16:36 AM

Previous topic - Next topic


Hi guys,

My sega Genesis model 2's player one port is stuck with the D pad in down. I've verified it's not the controllers by switching them out, and it's only in port one. I saw online that it's common for the solder points for the port to need retouching, so I hit them all with a fresh coat and it seems to still be stuck in down. I've tried a few passes on them, and the connections all seem to be solid. I recently moved and lost my multimeter, so haven't been able to check the connections yet but while I wait for the new one to come in from amazon I wanted to see if anyone else had any other possible suggestions?



My first thought was the controller, but you've ruled that out already.  I haven't got a megadrive to check, but...

Basically if it's ON all the time that means either the circuit from pin 2 (down, as seen on this schematic) is either connected to ground somewhere in the console, or the chip handling the inputs has failed. 

Interesting puzzle, I look forward to your results when you get the multimeter.  =D


Well I am now thoroughly confused!  ;D

Thanks for the response Lawrence. So I was able to test the continuity for the pins and everything seems to be in order. I was also able to confirm it's not grounding out to the RF shielding somewhere. I even tried plugging in a controller, touching the pin and touching the RF grounding, and when I push down I get a signal! So it seems up to that point it's functioning as intended. I was also able to confirm continuity up to the first, largest chip on the board and then I'm afraid my skills breakdown.

Based off your comment Lawrence I'm fearing it may be the input chip. Is there a way I can verify this to be the case?

Thanks again for the response!


OK, so we're clear, your multimeter beeps when you touch one end to ground, and the other to the DOWN input line from the controller, while you press down?  But it doesn't when you release the d-pad?

That sounds to me like the circuit outside the chip is working as intended.  My guess is the chip is bad, I don't know enough about the MD's guts to form any other opinion. 

Maybe someone else has a guess.


Hi Lawrence, that's correct. However something else I should note: The player 2 port seems to be functioning completely as intended when testing in games.

I'll continue to tinker around with it. Thanks!