January 23, 2021, 08:23:28 AM

Jamma PCB + PSOne LCD

Started by ken_cinder, January 14, 2007, 10:07:35 AM

Previous topic - Next topic

ken_cinder

Since this is my first post, I'd like to just give a general thank you to whoever happens by. I've made use of many guides and pieces of information I've obtained from GameSX and it's users.

Now onto my issue. I've wired up my jamma board to an NTSC PSOne LCD, and I'm having problems with the screen rolling. The colors are are right, everything is good.......except for this rolling problem.
I've tried all kinds of resistors on the sync line to no avail. If I hold the line with both hands, it syncs properly.....so I know my problem is definitely on that sync line. I just don't know how to correct it.

Segasonicfan

There are a lot of things you can do to fix sync fortunately.  Personally, I use a terrific Intersil chip, the ISL59885.  It has an auto-sync detection function and outputs both H and V sync from a C Sync or Composite video input.  

As for the PSOne LCD, you might want to try inserting the sync directly to the TFT encoder chip.  It's a MN5814 located by the ribbon cable plug.  Pin 1 is C Sync in, 2 is H sync in and 5 is V sync in if I remember correctly.  It's easy to find a datasheet on that though.

If all else fails you can try emailing JROK about a custom sync cleaner board he makes.  I haven't had any sync problems with my JAMMA boards so far so I haven't had use for mine but I've heard it can help a lot to clean arcade syncs.

-Segasonicfan

ken_cinder

January 15, 2007, 01:55:48 AM #2 Last Edit: January 15, 2007, 01:58:57 AM by IJTF_Cinder
My plans here call for being able to connect things like my Xbox and Gamecube via the composite 3.5mm jack. Hooking up a line directly to the encoder won't cause any issues with other sources will it?
Also, since I've got this Jamma board wired up via RGB, is it possible to make things Component compatible? I've got component cables for the previously mentioned consoles, and I'd rather use component over composite.

btw, my Jamma board is an original Double Dragon board. Standard resolution.

ken_cinder

Nothing doing in hooking up directly to the encoder, I get the same result.

Is it possible to put something in-line that will do (Abeit sounds silly) what my fingers on either end of the line do? Resistor, capacitor...anything?
If I touch both ends of the sync line while connecting, theres no sync problem, and once connected it doesn't go back out of sync.

ken_cinder

I got it! Weeee!

I put a 1kv 472z ceramic capacitor in the sync line and it stays sync'd! Now if I could only force the image to fill the whole screen it would be perfect. It's a bit underscanned and as such there is a black border on left/top/right.

viletim!

IJTF_Cinder,
You are trying to feed a TTL sync signal into a 75 ohm video input. They are not directly compatible - sometimes a direct connection works, sometimes it doesn't. A better solution (than the dodgy series capacitor) is to buffer the signal with a 74HC14 schmitt trigger inverter (use one gate to invert, all the rest in parallel to reinvert/buffer) and drive the video input through a resistor of about 820 ohms to drop the signal to the required level.

ken_cinder

January 15, 2007, 12:04:52 PM #6 Last Edit: January 15, 2007, 12:07:08 PM by IJTF_Cinder
I have no clue what you just said. My electronics skills are somewhat limited. :huh:

I've wired up RGB source directly to RGB output, the PSOne LCD is RGB, I only had problems with an unstable sync. I'm not wiring up to composite if I gave that impression.

Jamma     |   PSOne LCD
----------   |  -------------
Red          |   Red (Pin 11)
Green       |   Green (Pin 12)
Blue         |   Blue (Pin 9)
Sync         |   S-Video Y (I think?, Pin 5 AFAIK)
V-Ground  |   V-Ground (Pin 8)

viletim

Basicaly there are two different ways a monitor can receive it's sync signal. It can be sent by itself as a TTL digital signal (you know... +5v = 1, 0v = 0 type stuff) or it can stuck to a part of a video signal. In your case you monitor will only accept it's sync in "sync-on-video" style (when I say video I mean any kind of video - composite, luminance (Y), green, whatever..).

This pin you're sending your sync to is a video input (luma) and is terminated at 75 ohms (that is to say there is a 75 ohm resistor connected between this pin and ground inside somewhere). Now, when you connect your TTL logic signal to this 75 ohm input the signal drops to almost nothing.

To fix this you use another logic chip that has lots of "drive" between your signal and the video input. That way your signal can pass into the display without being crushed beyond recognition by the termination resistor.

Is that any better?
(ofcorse, no need to bother if your solution works for you)

ken_cinder

Makes sense to me, and would explain why a capacitor is getting the job done.

If I encounter any troubles with the sync in the future, I'll spend the time learning how to make a proper circuit like you suggested.
While we're on that topic, can you recommend any starter material online for learning electronics? I have a basic knowledge and I definitely want to learn more, but I can't find much that isn't confusing as hell (Due to it's premise that the reader isn't, a beginner)

viletim!

QuoteMakes sense to me, and would explain why a capacitor is getting the job done.
Acually, the way this works is extremely quirky. I won't go into details but it relates to the way sync is extracted from a video signal and the asymmetric drive of a logic chip made from bipolar technology (a logic 0 is an order of magnitude "stronger" than a logic 1).

QuoteWhile we're on that topic, can you recommend any starter material online for learning electronics?
Unfortunately, no. I know there are some good ones out there but I don't know any names. There's a book called The Art of Electronics by Horowitz & Hill. Which is what I'd generally recommend but it's not really a great introductory book. It is very readable though.

MaxamusCrasious

I could not find the link to the site for the life of me, so I decided to mirror the downloaded structure on my site.

http://www.maxamuscrasious.com/electronics.zip

ken_cinder

QuoteI could not find the link to the site for the life of me, so I decided to mirror the downloaded structure on my site.

http://www.maxamuscrasious.com/electronics.zip
I couldn't understand what your post was about at first. lol

I downloaded the file and then understood, unfortunately the archive is corrupt. Downloaded 5 times, and "Unexpected End of Archive" each time.