Author Topic: After a crash, X68000 XVI will no longer boot  (Read 194 times)

Offline MrKsoft

  • SmallMember
  • **
  • Posts: 2
After a crash, X68000 XVI will no longer boot
« on: August 07, 2017, 12:55:50 am »
Hi, I am seeking advice about what I can do about my XVI...

Before we start, I want to note that I have had this machine for about 3 months and it has been fully functional during that time (used maybe 1-2 times a week).  Got it off Yahoo Japan, and the seller stated that the system and PSU were fully recapped and the battery replaced with a CR2032 holder.  As far as I can tell from examining the machine, that is all true.

Yesterday I was just running MMDSP when the X68000 randomly hung.  After resetting it, I receive the message shown on the SRAM Issues wiki page. ("Error. Please reset the computer.")  So of course I go and check the battery... yep, it's on the borderline between alive and dead, with a low voltage.  It's conceivable it just happened to die right now.  So I swapped in a new battery and reset the SRAM by holding CLR while booting.

However... the error persists.  And unlike the page states, I cannot bypass it in any way.  Resetting with a disk in the drive either brings the same message instantaneously, or the system will access the floppy for a second or two and then stop on a black screen.  If I boot without a floppy, I can get the normal "please insert a disk" message.  Inserting a disk at this point has the same result: either a black screen or the error message.  Last night I got a few disks to do something different-- they asked for human.sys instead, basically saying the disk wasn't bootable... but they were bootable disks so I dunno what the deal is there.  After resetting a few times it went back to the usual error message and I haven't seen it again.

Repeated SRAM clears also do not help-- in fact, sometimes the error message is overlaid on the SRAM clear dialog and the system locks up, keeping me from doing a reset!  That sounds really bad to me...

Also of note is that 16mhz mode is now completely broke.  Booting at 16mhz causes the error to be printed on the left side of the screen, split across several lines.  Same with the SRAM clear dialog.  I've tried a lot of things now, and I am completely stuck at this point, and absolutely livid that so much money is down the drain if I can't fix this.  :(  What the heck happened!?

Here is everything I have tried:
-Replaced SRAM battery
-Cleared SRAM multiple times
-Attempted to boot the C Complier disk mentioned on the wiki page and reset SRAM that way (obviously, can't even get the disk to boot...)
-Removed SRAM battery, unplugged machine, left overnight in case the SRAM was badly corrupted
-Re-seated the expansion card riser based on some advice I received
-Re-seated all cables
-Swapped floppy drives

Does anyone have some insight, or do I now have a giant doorstop?

Offline Pinwizkid

  • BigMember
  • ***
  • Posts: 80
Re: After a crash, X68000 XVI will no longer boot
« Reply #1 on: August 08, 2017, 12:05:29 am »
Has the rest of the unit been capped? There are a few caps on the motherboard and a whole bunch on the interconnect board in the base. I'm not sure if your issue is directly related, but it's a good idea to do them as those caps are hitting the age where they will die and possibly leak. I just capped mine recently, it's a bit time consuming, but they are all gonna need to get done sooner or later.

Good luck and don't give up!

Offline MrKsoft

  • SmallMember
  • **
  • Posts: 2
Re: After a crash, X68000 XVI will no longer boot
« Reply #2 on: August 08, 2017, 07:20:06 am »
Crap.  Good thing I saved the translated version of the auction text... turns out my memory was wrong, JUST the power supply was recapped.  Bottom board was cleaned and the battery holder added but not recapped.  So that leaves everything else needing some attention then.  A quick inspection of the boards didn't show anything obviously leaking, but I know that means nothing in the whole scheme of things.  Unfortunately, I don't trust myself enough with a soldering iron to try recapping this guy, considering I can barely solder wires to battery terminals on the old 486s I've done without making a mess, so I'll have to find someone to help me out.

I'm hoping that isn't the immediate issue though, considering that it was fully functional 60 seconds beforehand.  I find it hard to believe that there would be a catastrophic failure like this due to caps, it's usually a more gradual issue.