Author Topic: Compact XVI - Screen Flickering on disk access  (Read 131 times)

Offline X-Col

  • MassiveMember
  • ****
  • Posts: 171
Compact XVI - Screen Flickering on disk access
« on: March 13, 2017, 11:54:46 pm »
Hi All,

I was going to sell my Compact due to it being unloved and unused in a cupboard. It needed a good home, and it found one.

However, when I come to test it I noticed that the screen was flickering quite badly whenever that Aztec Monster or the floppy drive was accessed.  :(

I couldn't, in all good conscience, sell it in this condition. It went straight back in the cupboard (until now).

I'm going to try and find out what the problem is, and fix it (hopefully).

Has anyone else encountered this issue, or any idea what the problem might be?

Thanks in advance  ;)

Offline kamiboy

  • ThrobbingMember
  • *****
  • Posts: 542
Re: Compact XVI - Screen Flickering on disk access
« Reply #1 on: March 14, 2017, 12:25:47 am »
I have the exact same problem on a OG X68000. I doubt it is a PSU issue since I swapped all the Capacitors on there, so if there is a problem there then surely it is due to some other component failing.

I am thinking it is prolly caused by some other failing Capacitor on the motherboard since I have not swapped any of those. It could also be capacitors on the floppy drive itself failing, though I find that less likely.

Offline X-Col

  • MassiveMember
  • ****
  • Posts: 171
Re: Compact XVI - Screen Flickering on disk access
« Reply #2 on: March 14, 2017, 08:23:11 am »
Strange as this computer is fully re-capped...

Must be a failing part somewhere  :'(

Offline kamiboy

  • ThrobbingMember
  • *****
  • Posts: 542
Re: Compact XVI - Screen Flickering on disk access
« Reply #3 on: March 14, 2017, 09:50:15 pm »
Oh, I was hoping it was something simple, like caps, but if your machine is fully recapped then I fear something more complicated is likely the cause...